Announcement

Collapse
No announcement yet.

Ready to run over my Earthmate GPS!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ready to run over my Earthmate GPS!

    I have had it with my Earthmate GPS Receiver. I'm ready to just run over the darm thing. I've probably spent in excess of 20 hours trying to get it to work reliably playing around with the drivers and USB to Serial drivers. It works sometimes and doesn't work most of the time.

    iGuidance is always complaining about needing to connect the GPS and my serial drivers complain there is no GPS found yet in my device manager it states no problem wit the device. I GIVE UP!

    This is going to be a question asked a million times already so flame me if you wish. I just want a reliable GPS receiver to work with my MII12000 that I can depend on to work every reboot or boot up.

    Has anyone got such a beast or know of such a beast? If so can you please provide me a link as I will buy whatever is reliable at this point so I can put this issue to rest.

    Soon there will be a S&T 2005 w/ Earthmate on ebay!

    I would be truely greatful for positive responses here

    A very frustrated person,
    Chuck

  • #2
    Garmin OEM 15L, awesome gps receiver, search around there are a few others of us using them.
    肚子笑痛了
    S60 Install

    Comment


    • #3
      I have a LT-20 working just fine with iGuidance. Im using the serial drivers and everything is at default. I currently have it outside the car, but it works fine. I did just order a new external GPS as I need something more weatherproof.

      How many pyhsical serial ports are you using? I wonder if you could be having a conflict somwhere. I have only COM1 enabled for my XM system, and the GPS virtual COM is COM2. The system is running on a VIA SP8000 mobo...

      Hope that helps, if you need more info on what I did, IM me...sipneat

      Comment


      • #4
        try this :http://www.mp3car.com/vbulletin/show...8&postcount=14
        make sure you have the earthmate and not the earthmate Lt20 model.
        Mercedes Benz CLK 430

        Comment


        • #5
          WOW super quick responses thanks.

          I have just the basic Earthmate (not the LT20) that came with my S&T2005. Currently have 2 serial ports configured on my MII12K (one for temp sensors and one for XM) and device manager shows the Earthmate as Com3.

          I've seen errors such as can not start device popping up once in a while.

          I am running an nLited system which was just recently installed with XPSP2. I would blame it on maybe nLite setting but I am having the same issues on my desktop PC with unreliability. It sometimes works and sometimes doesn't. I've uninstalled drivers and reinstalled a numbers of time trying to kick start this thing.

          The instructions state to connect the device and when the HID device is installed to then install the USB to serial drivers. Been there done that a few times.

          Mofo, thanks for thread link. I will try the suggestions in there this evening to see if it resolves the issues I'm having. I have tried those drivers and actually thats what I have installed at the moment. I had iGuidance working using SKINbedder within RR. I rebooted the PC and now I can't get the GPS workin again. If I reboot a few time I may end up getting working again and this how it has been over the course of the last few days. I just can't get it working reliably.

          Thanks,
          Chuck

          Comment


          • #6
            The GPS that comes with Streets and Trips 2005 is a Pharos iGPS360. Does yours have the Microsoft Logo on it. If so, order another GPS. The iGPS 360 is not reliable. It hates heat also. I dumped mine and bought a GPS engine board and external antenna. No problems since.

            Look at :

            http://www.mp3car.com/vbulletin/showthread.php?t=52858

            http://www.mp3car.com/vbulletin/showthread.php?t=53448
            If It's Called Tourist Season, Why Can't We Hunt Them?
            I Just Do What the Voices Inside My Head Tell Me to Do.
            The Definition of an Upgrade: Take old bugs out, put new ones in.
            Texas DOS: Y'all reckon? (Yep/Nope)

            Comment


            • #7
              I don't recall seeing a MS logo but I will check this evening.

              Has anyone tried one of those CF Slot Receivers like what a handheld would use? I'm not using the CF slot on my MII12000 so this could potentially be used for a receiver. Of course the receiver would need to have an external antenna attachment.

              I do know that USB inself can unreliable but my only two COM ports are already dedicated. I was planning to use one USB for an external drive to hold my media and one for the USB receiver. I have a 1G CF card running of a CF to IDE adapter because the MII12000 does not support booting from the CF (although I guess folks have it working for Linux). I'm kind of limited on how many ports I have remaining so really I have USB and the CF slots.

              Chuck

              Comment


              • #8
                Originally posted by MoFo
                try this :http://www.mp3car.com/vbulletin/show...8&postcount=14
                make sure you have the earthmate and not the earthmate Lt20 model.
                Hi MoFo, They only have the USBEMate2.exe file in this link. Does this one not work correctly because I did try this one and it still caused me problems.

                It's seem this file was updated in Oct of 2003.

                Thanks,
                Chuck

                Comment


                • #9
                  ive got the earthmate usb version it works fine with iguidance and delorme serial splitter play wit it a bit more maybe it will work

                  Comment


                  • #10
                    Anyone try this version of the driver. The USBEmate2.exe file does not have a USB Serial option. The option when selecting the driver is a HID device. This file may not be correct so how about this one. I did try with no luck but I'm going to try uninstalling everything and try the reinstall route.

                    Suppose to be for both the Earthmate and the LT20.

                    http://www.delorme.com/support/gps/lt20001.asp

                    Thx,
                    Chuck

                    Comment


                    • #11
                      Finally getting some error in Device Manager. It is stated as a Com 3 device but the properties show that it can not start the device.

                      Wonder if it could be the nLite install causing this? I used the ini found in the nLite thread. I'm sure other have Delorme Earthmate working with that ini.

                      Chuck

                      Comment


                      • #12
                        Originally posted by chuckster
                        Anyone try this version of the driver. The USBEmate2.exe file does not have a USB Serial option. The option when selecting the driver is a HID device. This file may not be correct so how about this one. I did try with no luck but I'm going to try uninstalling everything and try the reinstall route.

                        Suppose to be for both the Earthmate and the LT20.

                        http://www.delorme.com/support/gps/lt20001.asp

                        Thx,
                        Chuck

                        This link is only for the LT 20. Dont use that one.

                        I have the earthmate also. I used the file in the link i posted earlier (USBEMate2.exe) and did all the steps i posted about in that same previous link.
                        Uninstall everything, and follow the instructions I wrote in that post. Dont skip any steps and make sure your not changing into different USB ports.
                        Let me know exactly what heppens..
                        Mercedes Benz CLK 430

                        Comment


                        • #13
                          Originally posted by chuckster
                          Anyone try this version of the driver. The USBEmate2.exe file does not have a USB Serial option. The option when selecting the driver is a HID device. This file may not be correct so how about this one. I did try with no luck but I'm going to try uninstalling everything and try the reinstall route.

                          Suppose to be for both the Earthmate and the LT20.

                          http://www.delorme.com/support/gps/lt20001.asp

                          Thx,
                          Chuck
                          Use USBEmate2.exe for your Earthmate. The link you give is for LT20 (I tried it and it screw me up BIG time).

                          - Leave the GPS plugin and uninstall the driver using Windows's add/remove program.
                          - Remove anything assocciate with the GPS in device manager.
                          - Unplug the GPS.
                          - Reboot the machine.
                          - Install USBEmate2.exe.
                          - When ask or when the installation finish, plug the GPS in (try different USB port than before) and Windows will recognize it as a HID device.
                          - Select that HID device -> Property-> Update driver.
                          - Select "Install from a list or specific location (Advance)" and Next
                          - Select "Don't search. I will choose ..... " and Next
                          - Select "Delorme USB ...... " and Next
                          - Select "Continue Anyway" on unsigned driver warning.
                          - Enjoy.

                          I have both Earthmates and they work without a single problem either reboot or hibernate.
                          Do you connect it directly to the mobo's USB port or thru a hub?
                          I connect it to the hub along with TS, Mouse/trackball, KB (all USB1.1 devices).
                          2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                          89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                          Y2K Accord Dell GX150
                          RoadRunner is the best FE PERIOD
                          EmoRebellion is a SCAMMER

                          Comment


                          • #14
                            Well I followed the instructions here and I have the serial driver loaded and it appears to be running fine as it indicates com3.

                            Problem now is iG will not find it when doing an auto detect. I tried setting it as com 3 with the default baud as 4800 and I tried baud 9600 and I just can't get iG to see it.

                            If iG doesn't see it it will not embed properly in RR.

                            Chuck

                            Comment


                            • #15
                              Search and download 2 programs called Compass and Xport2 by Curiosity, a member here. Those 2 programs work together to create virtual ports so that you can use multiple GPS apps with 1 receiver. Those are free. If you want to pay, google for GPSGate. They have 30 day trial (I think).
                              Maybe these programs help the problem you have with iG.
                              2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                              89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                              Y2K Accord Dell GX150
                              RoadRunner is the best FE PERIOD
                              EmoRebellion is a SCAMMER

                              Comment

                              Working...
                              X