No announcement yet.

Garmin GPS - driver problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Garmin GPS - driver problem

    I have a Windows XP instance running under VirtualBox. I managed to install the MapSource software from Garmin. I even managed to get the many USB problems for VirtualBox solved, and now can see an 'unknown device', which happens to be the Garmin under Windows. I know it's the Garmin, because I compared the device/vendor ID. Anyway...

    When I start MapSource, it cannot find the device. When I look under the Windows device manager, it shows me this unknown device, with a yellow question mark next to it. It's not fully operational.

    I looked into the Garmin install directory for the drivers, and tried to force an install of the USB drivers for the Garmin, but the Windows 'new hardware' wizard tells me that it cannot find any better driver for the device than the one it has installed already, which just happens to be some generic USB driver.

    Does anyone know what I could try next? How can I force Windows to use the drivers that I have specified?

    I know this sounds like a Window question, not a Ubuntu one. But apparently, this problem would/should not exist if I would run Windows natively, instead of VirtualBox...

    Any help is greatly appreciated...