No announcement yet.

Calculating routes takes way too long

  • Filter
  • Time
  • Show
Clear All
new posts

  • Calculating routes takes way too long

    I'm using 5.00.70 and I really like the software overall. It just takes so long to calculate routes. Even something that is 10 miles away takes a minute or more to calculate. This makes the program useless for me.

    When I first installed it, it seemed to calculate quickly but after installing this plugin: it now takes forever! Perhaps it is just a coincidence. I only tried calculating like one route before installing the plugin. I don't see why this should slow it down though. Its not just slow in CF but is slow even when just running GMPC by itself.

    This is under XP SP3.

    Any thing I can do to fix this? I'd really like to use this software but I can't afford the 1+ minute wait.

  • #2
    If the plugin modifies core GMPC files (it used to-not sure if it still does), theres a pretty good chance its the cause. Routes usually don't take anywhere near that long even on very slow hardware.
    openMobile - An open source C# Front End (why choose openMobile?)
    - Always Recruiting Developers -
    Like what you see? Donations are always welcome


    • #3
      what hardware are you running?
      Fusion Brain Version 6 Released!
      1.9in x 2.9in -- 47mm x 73mm
      30 Digital Outputs -- Directly drive a relay
      15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
      Buy now in the Store


      • #4
        Originally posted by AltimateX View Post
        When I first installed it, it seemed to calculate quickly but after installing this plugin: it now takes forever!
        If it were me, I'd uninstall that plugin and GMPC (possibly CF as well), then reinstall GMPC (and CF ). Likely the routes will calculate with better times, meaning the plugin was the problem. Which is usually the case when a plugin messes with the core operating files of the program.


        • #5
          lol its got nothing to do with the plugin. It'd take 10 seconds to run GMPC in standalone and check that.

          What are the system specs
 Senior Tech Blogger (Want a product reviewed? Contact me.)
          Follow Me on Twitter or Facebook
          Live mp3Car Facebook Chat


          • #6
            Interesting. I didnt think they made computers slower than my 2003 Vaio, which calculates routes in about 4 seconds, so unless he's running it on Pentium 3, it's certainly possible its the plugin which development seems to have dwindled. So I still vote to uninstall the plugin and GMPC, then reinstall GMPC. Im almost positive this will fix it.

            Validated by this statement:
            When I first installed it, it seemed to calculate quickly but after installing this plugin: it now takes forever!


            • #7
              Sorry guys. I asked this question and never followed up after you guys were kind enough to try to help me.

              This is on a Fujitsu P1610 convertible. It has a 1.2GHz Intel Core Solo and 512MB Ram. I know its a little slow but when running the Garmin software I still have 175-200mb available ram and plenty of cpu headroom. My cpu usage is well below the 50% mark when trying to calculate the route and at times virtually no cpu activity is shown. So, I really don't think this is a processing issue. I just tried installing it with a fresh install of XP Pro SP3 (tablet edition) and it still takes forever. So even on a fresh install with no Centrafuse or the plugin, its still too slow.

              I tried running it on a more powerful machine under a virtual machine and had the same issue.

              Perhaps this is an intentional limitation of the demo?


              • #8
                So this is a demo version?


                • #9
                  Originally posted by ws6vert View Post
                  So this is a demo version?
                  Yeah, a 15 day trial if I remember correctly.


                  • #10
                    It is possible that the problem lies with the maps rather than the program.

                    If the maps have any corruption in them, it breaks the way the software routes, causing dead ended nodes.

                    I would definitely try what others were saying....uninstall GMPC, the maps and the plugin as a minimum, then reinstall just GMPC, test that on its on (Not in CF), then install the maps you require and test again, then install the plugin, and test again.