Announcement

Collapse
No announcement yet.

CONTEST: Xbox Chatpad Driver Challenge

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hello guys,

    I've installed all the drivers and run chatpad_control but chatpad not works.
    Description:

    What steps will reproduce the problem?
    1. F8 after bios - disable drivers check (or smth like this)
    2. run chatpad_installer_amd64 - pressed ok everywhere, when windows ask if its needed to install - said yes, everything ends successfully
    3. run chatpad_control_amd64, black window with some lines of text appears - copy-pasted that in bottom
    4. chatpad dont light or respond on pressing keys (
    5. controller itself works.

    What is the expected output? What do you see instead?


    What version of the product are you using? On what operating system?
    -wired controller (think its official windows controller (red package, screws with a "star", windows itself install xbox wired controller drivers for it)
    -im not sure if chatpad is official thing where i bought it - but windows install xbox handset drivers when after my first connection chatpad to controller
    -100% official windows 7 home edition, intel core i-7, 64

    Please provide any additional information below.
    From the "black window after chatpad_control_amd64 lunch":

    *****
    Chatpad control utility version 0.1a started.
    *****
    Please wait...

    Control utility started.
    Opening chatpad filter driver.
    Successfully opened chatpad filter driver.
    Successfully connected to XBox 360 controller.
    Opening connection to virtual keyboard device.
    Successfully opened connection to virtual keyboard device.
    Successfully connected to the virtual keyboard device.
    Opening connection to virtual mouse device.
    Successfully opened connection to virtual mouse device.
    Successfully connected to the virtual mouse device.
    Microsoft initialization has been finished, so we can init the chatpad now.
    IOCTL failed, lastError == 31
    IOCTL failed, lastError == 31
    IOCTL failed, lastError == 31
    Successfully sent IOCTL. Bytes transferred: 2
    Control response data received: 0x09 0x00
    Successfully sent IOCTL. Bytes transferred: 2
    Control response data sent: 0x09 0x00
    Successfully sent IOCTL. Bytes transferred: 2
    Control response data received: 0x09 0x00
    Successfully sent IOCTL. Bytes transferred: 3
    Reading thread started for controls data.
    Worker thread started for mouse data.
    Reading thread started for chatpad data.


    Maybe the problem is that im using not official chatpad?
    Click image for larger version

Name:	images (1).jpg
Views:	1
Size:	5.6 KB
ID:	2287745Click image for larger version

Name:	images.jpg
Views:	1
Size:	3.9 KB
ID:	2287746
    Mine is with the additional ledge at the bottom.

    Comment


    • Hello, I'm interested in helping to develop this, if it is still being worked on. it seems we have a working driver for wired, that just needs a bit of polishing to make it a bit more user friendly. I wouldn't mind helping to do that.

      Also I am having a strange issue with GAFBlizzard's drivers. I got them to work once, but every time since they haven't worked, all the buttons, (including the main controller buttons don't work, and some combinations of modifier keys + a button show "No binding found for: <hex code>". It looks like all the buttons have been mapped to nothing, but I am using the default config file with no changes. I am running this on windows 8.
      Last edited by TheShryke; 12-28-2013, 10:23 AM.

      Comment


      • Originally posted by TheShryke View Post
        Hello, I'm interested in helping to develop this, if it is still being worked on. it seems we have a working driver for wired, that just needs a bit of polishing to make it a bit more user friendly. I wouldn't mind helping to do that.

        Also I am having a strange issue with GAFBlizzard's drivers. I got them to work once, but every time since they haven't worked, all the buttons, (including the main controller buttons don't work, and some combinations of modifier keys + a button show "No binding found for: <hex code>". It looks like all the buttons have been mapped to nothing, but I am using the default config file with no changes. I am running this on windows 8.
        Yes someone who's not dead that wants to work on this. I really need a fick for the wired version. everytime I open the controll utility it closes again after saying please wait... yes I tried admin etc. I would love for someone to check that out bought a brand new chatpad thinking this driver works.

        Comment


        • I want to work on it, but ill need the source files before I can do anything

          Comment

          Working...
          X