Announcement

Collapse
No announcement yet.

When Good touchscreens go Bad !

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • When Good touchscreens go Bad !

    I have been using a nice 8" touchscreen that I got on e-bay about 3mo ago (new from Hong-Kong).
    Everything has been great.
    A couple days ago the monitor went crazy. After about 1/2hr of flawless in-car operation the mouse pointer jumps to the top right corner, starts erratically moving around and clicking whatever is there.
    It even managed to create some kind of tool bar on the windows desktop, something that I didn't know was possible...

    I thought that maybe signals from other USB devices all connected to the same hub get intermixed, so I unplugged everything but the touchscreen - same problem.

    Please help!

    Thank you,

    Boris.

  • #2
    You don't happen to have a serial GPS device do you? I've noticed sometimes mine will startup and recognize it as a serial mouse and start going crazy. Or do you have the touchscreen's data cable (usb, etc) running near other signal /power cables?

    Comment


    • #3
      I have a USB GPS, and I unplugged it.
      The usb bundle does run close to speaker wires, power wires, etc.. its a big mess now.
      You think thats the culprit?

      Comment


      • #4
        Speakers are magnetic and could possibly be distorting signals. However, I'm no expert.

        Comment


        • #5
          The problem is that Windows is reading the GPS device as a mouse. To overcome this go to the device manager and disable the "Microsoft serial mouse". Simple when you know how
          VIA M10000
          512Mb RAM
          30Gb 2.5" HDD
          Bluetooth, 802.11g, GPS
          Silverstone USB DAC
          Consult (ODB)
          CarTFT K500
          Carnetix P1290
          NLited XP with Road Runner and MapMonkey

          Comment


          • #6
            Originally posted by Tim Lake View Post
            The problem is that Windows is reading the GPS device as a mouse. To overcome this go to the device manager and disable the "Microsoft serial mouse". Simple when you know how
            he said the gps unit is unplugged but still doing the same

            Comment


            • #7
              My mouse/Touchscreen just started doing the same thing. Moving to topy right and clicking on things. I did install a DeLorme serial port emulator last night, and it all worked fine. Tonight I was in Road Runner and it just started acting flaky. I also tried unplugging extra USB devices, but not the GPS. I will check tomorrow if the Microsoft mouse crap is causing the issue.

              Comment


              • #8
                my screen did the exact same thing before it stopped responding to any callibration attempts...if anyone knows a fix, please do tell...do tell...i only had mine installed for about a week...no mouse connected, no USB or serial devices at all, just the monitor attached to the mobo and only drivers for the mobo, sound card, and monitor were installed...no GPS, no bluetooth, no wifi..nothing...and a clean/fresh install of XP Pro
                Trouble deciding on car speakers? Clicky Clicky
                Speakers: DLS Ultimate Iridium 6.3 Link
                Subwoofer: removed
                Amplifier#1 (Front Stage): DLS Ultimate A4
                Amplifier#2 (Sub) removed
                Carputer: Removed for tablet install

                Comment


                • #9
                  The same just happened to me.

                  No change in cable routing, no change in programs or added components.

                  Any one find a fix?
                  96' SLK 230 Kompressor
                  HR sprigs -> Done
                  19' wheels -> Done
                  Projector headlights -> Done
                  Carpc -> 85%

                  Comment


                  • #10
                    A fresh intsall didn't help, and attatching the display to another computer (without drivers) resulted in the same thing. I've started talking to MP3Car.com support, and they've had me try all the things listed in the forums... I think I'm going to talk to them over the phone to determine an approximate cost for repair tomorrow.

                    Comment


                    • #11
                      Originally posted by bmassey96 View Post
                      A fresh intsall didn't help, and attatching the display to another computer (without drivers) resulted in the same thing. I've started talking to MP3Car.com support, and they've had me try all the things listed in the forums... I think I'm going to talk to them over the phone to determine an approximate cost for repair tomorrow.
                      I actually just got it working like a charm again!

                      My screen is a 7" no brand from the ebay seller "tammy2918".
                      (like this one http://cgi.ebay.com/ebaymotors/Headr...QQcmdZViewItem)

                      The following driver and program had these data's:
                      touch screen utility
                      4.0.2.1618

                      I searched on 4.0.2.1618 and found out that I could be the same drivers that the xenarc screen used,

                      I just downloaded the latest driver I could find on from them (Version 4.3.7.3321 (09/25/2006)):
                      http://www.xenarc.com/driver-touch1.html

                      I uninstall the drivers and tried the new one.
                      And WOW now everything is working again!!

                      But I can't say I know why..
                      I had the same set up, no change in sw or hw, and had used the screen for about 3 month with no problems before this happens.
                      The only thing I could see that may have changed is downloads thrue windows update..

                      Anyway, why don't you try do the same?
                      maybe you to get lucky
                      96' SLK 230 Kompressor
                      HR sprigs -> Done
                      19' wheels -> Done
                      Projector headlights -> Done
                      Carpc -> 85%

                      Comment


                      • #12
                        I'm having similar problems with my touchscreen. The mouse moves to the top left and randomly moves and clicks. Interestingly this only lasts about 5-10mins and then everything is ok until a "long" resume from hibernation (hibernating and resuming straight away doesn't cause the problem to re occur???).

                        I do have a usb GPS but unplugging it doesn't stop the mouse but unplugging the touchscreen usb stops the mouse from moving. I tried installing the latest touchscreen drivers and that didn't fix it, but I did notice windows saying something about a serial mouse detected then failed to install it.

                        This is driving me insane...... Anyone have any suggestions?

                        Comment


                        • #13
                          I had a similar problem, it was dirt in the bezel around the screen itself, I guess it was pressing on the touchscreen in the corner. Mine also gets dust on it on a regular basis, but that may not be your issue.
                          "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
                          RevFE
                          My Shop

                          Comment


                          • #14
                            Yeah I thought of that, but the fact that this only lasts about 5-10mins after resuming from hibernation makes me think its a software issue. Plus its going to be a pain taking out the touchscreen.

                            Comment


                            • #15
                              Hello. I'm having i think the same problem, I received the monitor from tammy on saturday, so i install it on sunday, and it start to work fine, then on monday it start to stay in the corner, I contacted tammy and told to remove the plastic that the screen come to protect, so I did. Started to work again until I closed the monitor, when I open it again, the mouse did not move and it did not respond to any touch, I check the drive and is there by looking under device, even if a unplug the usb from the hub it recognize that it have been unplug. Any Suggestion?. Thanks in advanced!!!!

                              Comment

                              Working...
                              X