No announcement yet.

Lilliput 629 (transflective) touchscreen problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Lilliput 629 (transflective) touchscreen problem

    I've had this since March, this is the 2008 model. It worked great for about the first 2 weeks, then I noticed I've had to calibrate it about once a week.. then it later it came down to once every 3 days.

    Fast forward to about 3 weeks ago. I can no longer calibrate it to where it works. I try the 4 point calibration, clear and calibrate, 9 point, 25 point. Any of them, after i finish, the mouse just jumps to a corner and sits there no matter where I touch it.

    Now as of a few days ago, the touchscreen no longer recognizes any touches. If you try the 4 point calibration, it doesn't even detect being touched anymore.

    I'm pretty sure the driver is good as it worked great initially - I'm using the egalax one and I've updated that as well to see if that would fix it. To see if it was maybe my system I pulled the screen out of my car and tried it with another computer and it detects the touchscreen when I plug it in the USB and I give it the driver I've used in the car, but again when you try calibrating, no detection of touch.

    Any ideas?

  • #2
    If the pointer is going to one corner, that usually means that there is something stuck between the bezel and the TS overlay. It also sounds like it could be a controller problem. I'd try to take it out of the case and then calibrate it. If that doesn't work, a new controller costs $40 or so.

    If you want, you could try to contact the MP3car store and see if they'll do warranty service on it, it's only 3 months old.
    03 Accord Sedan CarPC


    • #3
      I think these screens only have a 60-day warranty. If it's a controller problem, where can I purchase one from?


      • #4
        I know people use eBay quite often. I wouldn't know otherwise. I'm sure there are other places, just ask around.
        03 Accord Sedan CarPC


        • #5
          i had this problem too.
          it is not the touch screen, it is your DSATX power supply RS232 Brainstem diagnostics acting as a mouse.
          try unplugging the diagnositic brainstem from your comm port and see if it makes a difference


          • #6
            I had a problem like that when I modded it into my dash..but the problem was that the screws were too tight. on the corner the mouse kept going I loosened it till it was fine on that corner it kept going to...just a thought.


            • #7
              I'm actually having a similar problem with my 629. I updated the drivers but that didn't seem to help. It will work correctly for a couple days then the mouse pointer will always goto the bottom left corner. I'd be interested in any solution you came up with.


              • #8
       if you need only the controllerm, i have replace it on my lilliput and works well.


                • #9
                  I ended up RMAing and sending it back. It was discovered some solder work was needed to fix it. After a few weeks I got it back and it works perfect now.

                  Thanks Goce!