No announcement yet.

lilliput won't work - USB device not recognized...

  • Filter
  • Time
  • Show
Clear All
new posts

  • lilliput won't work - USB device not recognized...

    I just got my 7" lilliput touch screen - looking to put it into my car, but I tried hooking it up to my computer first. When I plug it in to a USB 2.0 port, the entire computer hangs until I unplug it. I read about some problems with multiple usb ports so I tried it on another computer (with windows XP Pro) - I installed the drivers, unplugged the usb cord then plugged it in again, and got the message "USB Device Not Recognized" saying that a device connected has malfunctioned.

    I tried this on 3 other seperate computers (all with XP) and got a USB device not recognized on all of them. Everything is great except I cannot get any computer to recognize this device. I have tried everything I have read in the threads (rebooting and replugging in - updating drivers) but nothing has worked. Is this a defective touch screen or is there some configuration problem with XP? Help!


  • #2
    did you reinstall the USB 2.0 BUS drivers or the Lilliput drivers?


    • #3
      Lilliput Drivers. It's supposed to support usb 1.1 and I have tried it with a lot of different computers (Mainly USB 1.1). I realized that the usb 2 problem I was having was with a hub conflict because when I rebooted with the touch screen plugged in, no other devices loaded, but when unplugged, the other devices proceded to load. I've started working on 2 main computers one with a single 1.1 port and one with duel 1.1 ports. Neither locks up, but both give me a USB not recognized error. Any idea (hope my stammering helps explain things)?


      • #4
        do you have the USB cable in the correct slot on the lilliput, some people have said that there is a port on the side of the lilliput that looks just like a USB slot but is for a (sepeate power)? i have never seen a lilliput but that was someones problem previously, and have you tried a 2.0 USB computer running W2k?


        • #5
          Yea - there is no other slot on this version - the VGA cord is directly wired in and the usb cable splits out from that (if you've ever seen a wireless keyboard/mouse setup - its like that) so I can't plug in the usb anywhere else. I also don't have access to anything except WinXP (and Win98 but i would rather not have to reformat or reinstall an operating system). It just won't recognize it (I'm beginning to think that I got a bad usb cable or touch screen because a device shouldn't get this message). Is your lilliput a usb?


          • #6
            hmm thats very strange, they should all be 2.0 compliant, and i've never heard of anyone with the problem your having, maybe contact the suppliers about a defective unit =/


            • #7
              Thats what I was thinking might be up. Thanks for the help.


              • #8
                my lilliput did the same thing, your touchscreen is probably out... mine is.
                2011 Nissan Frontier SL
                AMD X3 2.2 | M4-ATX | 16Gb SSD | 2GB DDR3-1333 | MSI GF615M-P33 MB
                OBDPROS USB | BU-303 GPS l LILLIPUT TS | Car2PC adapter | XM Direct | USB Dual band N with custom mag-mount antenna.


                • #9
                  Just a quick FYI I had this same issue with the lillput on about 5 different PC's.....all running XP...

                  Simple solution for me was to install the touchkit drivers. Here is the site...they are the same thing that comes with the lilliput but it isn't branded and they are updated....

                  Click Me!!!

                  Go there and scroll on down to the XP drivers....make sure all the other software that was install is off the system and then install these. ever since doing that my lilliput has worked on all my systems with no problems.

                  Hope that helps


                  • #10
                    Nope - Non branded drivers didn't change anything - the USB Device is still unrecognized. I'm quickly coming to the conclusion that the touchscreen is shot and I'm going to have to send it back. Any other ideas? Thanks for the help.


                    • #11
                      im sorry to hear that theres a 1 yr warranty, so good luck man


                      • #12
                        I know about your problem..

                        The problem is discusted in a german forum (
                        The Manufactur send the wrong cables for the TFT/Touchscreen with it..

                        Replacement is on the way, but stucked in china because of the typhoon..

                        You should ask your reseller about this issue.. he should already know about that...


                        • #13
                          I have same problem with my, and it will donīt help with the ney cabel I got...


                          • #14
                            then you've still the wrong cable.. trust me on this.
                            tell your reseller that he should contact his supplier...


                            • #15
                              Same Issue

                              Installed the Lilliput display on my desktop to test it. Couldn't get it to work from a USB 1.0 hub plugged into onboard USB 2.0. Plugged it into the onboard USB 1.0 and got the touch screen working. Just finished building my mini-itx machine last night. Everything working fine, have XP SP1 installed. When I plug in the Lilliput USB touch screen directly to the motherboard USB 2.0 the new system does not recognize it.

                              Lilliput -> USB 1.0 hub -> USB 2.0 onboard = dead

                              Lilliput -> USB 1.0 on motherboard = works

                              Lilliput -> USB 2.0 on motherboard = dead

                              The fact that the hardware is not being recognized on USB 2.0 leads me to believe that the Lilliput USB hardware is flakey. I'm gonna try a few more tests tonight. My desktop has USB 1.0 on the motherboard and 2.0 on a PCI card. I'll post any significant results.
                              2001 Ford Expedition
                              M10000/1Gb/250GB, Lilliput 7", Custom Dash