Announcement

Collapse
No announcement yet.

touchscreen & com port?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • touchscreen & com port?

    did a bit of searching on this issue, but haven't really come to any conclusions on it. so maybe someone can help me out with this one.

    i have a lilliput touchscreen and haven't been using it too much lately because it's been driving me crazy. it's almost nearly impossible to calibrate correctly, no matter what i try. but i discovered that if i disconnect the GPS receiver (which is also USB), the touchscreen works perfectly. plug it back in and the calibration goes to *****. so i'm wondering if it could be any of the following:

    1) com port issue: i installed the drivers for the GPS mouse BEFORE the drivers for the touchscreen. should i have done it the other way around?

    2) USB power issue: could it be that the touchscreen isn't getting enough power once the GPS mouse is plugged in?

    3) some other issue that i'm not aware of.

    any help would be greatly appreciated. i'd like to first try to troubleshoot the problem without having to spend any more money (i.e. physical hardware problem). thanks in advance.
    Mazda 6 Carputer

    elocine.net {NEW ALBUM AVAILABLE FOR FREE!!!}

  • #2
    It sounds to me like your GPS driver is capable of working off USB also. I say that because it seems like your driver is sending info out to the USB devices “looking” for a GPS. It obviously finds the GPS on the com port but continues sending info out the USB or you wouldn’t continue to have the problem. I don’t know. I just took a stab in the dark. Try uninstalling your GPS driver but leave the GPS device plugged in. Then you would know it is related to the driver only.
    My Work Thread:
    http://www.mp3car.com/vbulletin/showthread.php?t=72552
    Source switcher for Lill
    http://www.mp3car.com/vbulletin/show...d=1#post841007

    Comment


    • #3
      1) the order shoudlnt' matter

      2) could be, try to use a hub. but doesnt' sound like it, more like a conflict to me.

      3) conflicts are rare with usb, but they could happen. try to uninstall both devices in device manager. see if that helps
      Current:
      [BMW E46 ///M3 Convertible]

      Previous:
      [BMW E31 850CSi]|[BMW E39 535i]|[BMW HVAC Research]|[IBUS Scrolling Text]|[BMPuter]|[Velocity]|[TomTom]|[Vision]|[Space Navigator Driver]|[Super Fast Boot]

      Comment


      • #4
        i've done quite a bit of research and troubleshooting in the past day or so, but nothing seems to work. it was working perfectly fine this morning, but now the touchscreen panel doesn't even respond at all anymore. windows still detects the usb controller, so i suspect it may be a problem with the TS panel itself. after all, it has been sitting in my car for two years now. i've already ordered a new one, so we'll see if that fixes it.
        Mazda 6 Carputer

        elocine.net {NEW ALBUM AVAILABLE FOR FREE!!!}

        Comment


        • #5
          Sounds out there -- Power flux issue? are you running @ your PSU's max and its having problems giving power out to your USB items?
          Jim
          2012 Honda Pilot (In Progress)
          2010 Honda Accord (After the Pilot)
          2008 Honda VTX1800N

          Comment


          • #6
            Im having a similar issue. The pointer will just jump all over the place. I've tried every combination... of installing, reinstalling, com port selection... and it will work and the drivers will stick... till the next boot up. Im going to do some more research on the device IDs.

            MB: MII10000
            screen: lilliput
            GPS: Duleo

            Comment


            • #7
              i'm pretty sure that it was the touchpanel on mine that went bad. i replaced the entire monitor with the newer lilliput and everything works perfectly. i had ordered a replacement touchpanel from digitalww, but it was cracked when i received it. still haven't been able to get in touch with armen about it, so i'm still waiting to get another one to see if that was really the problem.
              Mazda 6 Carputer

              elocine.net {NEW ALBUM AVAILABLE FOR FREE!!!}

              Comment


              • #8
                Hi

                I've also a touchscreen & com problem with my innovatek 8'' tm-868 touchscreen. When I install drivers (downloaded from http://www.egalax.com.tw) http://www.egalax.com.tw/drivers/Win...4.0.2.1929.zip
                it freeze my winXP pro just after I've click continue installation without digitaly signed driver .... ... (ps2 driver not installed)

                I've tried several driver's version always the same problem.

                The touchkit software is installled but doesn't recognise my touchscreen.

                I've tried to install my touchscreen on my desktop and no problem, everything working fine.

                I think the problem comes from my sony vaio tr5mp, because it's doesn't have any physical com/ps2 port. My integrated bluetooth emulate a com port and also my gps mouse receiver which probably interfer with my touchscreen.

                Comment


                • #9
                  you're probably getting a hardware config error. my my advice would be to uninstall all comports/blutooth adaptors etc and start again.
                  Current:
                  [BMW E46 ///M3 Convertible]

                  Previous:
                  [BMW E31 850CSi]|[BMW E39 535i]|[BMW HVAC Research]|[IBUS Scrolling Text]|[BMPuter]|[Velocity]|[TomTom]|[Vision]|[Space Navigator Driver]|[Super Fast Boot]

                  Comment

                  Working...
                  X