Announcement

Collapse
No announcement yet.

Stop resuming from standby by touchscreen?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stop resuming from standby by touchscreen?

    Hi,

    when my system is in standby (STD) and I touch the screen, it resumes. Can I stop that? I don't wanna wake up my computer via touch! Are there any solutions?

    TIA,
    Basti

  • #2
    That depends.

    The easiest would be to tell it not to wake up by USB. There is a checkbox you can get to in the control panel that allows or disallows this. In addition many motherboards have such an option in the bios.
    My Install

    Comment


    • #3
      The problem is, I have this checkbox at the network card, but I can't find a checkbox at any USB device!?

      Comment


      • #4
        check the bios for any related settings

        Comment


        • #5
          No related settings, I though there are, but that option is already disabled, Any other suggestions?

          Comment


          • #6
            Do you know if your system is going into Sleep S1 or full on S3 state? S1 leaves some things running, S3 is a much deeper sleep (and S4 is hibernate). Check your BIOS settings and make sure that turning on via mouse/key click is disabled. ACPI should be on in bios, and your "computer" device in device manager should have the word ACPI in it, not "standard PC".

            To get the powermanagement checkbox to appear in device manager for USB devices (that support it), you have to do some registry editing. I'm not responsible if your computer messes up, but it worked for me. Make a system restore point if you are worried.

            Start, Run, type in regedit and press enter.
            Go to HKLM\SYSTEM\CurrentControlSet\Services
            Look for a key named USB or usb. If it's not there, create it.
            Add a DWORD with the name USBBIOSx inside that key, and give it a value of 0 (it should show up as 0x00000000)

            Reboot, and you should have the checkboxes in device manager, for your USB devices that you are looking for. It might be under the mouse too, depending on your touchscreen driver.

            If the powermanagement tab doesn't show up, uninstall your USB devices (from device manager) and unplug them, then reboot. Once XP is back up, plug them in, and it should appear.

            To change your sleep state when a standby event is called upon, you can use a microsoft tool called dumppo.exe

            ftp://ftp.microsoft.com/products/Oem...cpi/dumppo.exe
            save to your windows directory.

            Open a DOS window (Start, Run, CMD, enter),
            type:
            dumppo admin

            And it will show you what state it's set to go to. If it's S3, and you want S1 to resolve an issue or hang like I did, you can then type:

            dumppo admin minsleep=S1

            And it will force S1 from that point on.

            Durka Sherpa Durka Durka... Matt Damon!

            91 Stealth RT/TT
            CarPuter: Inspiron 5150 P4 3.0ghz; Built-in WiFi; Deluo GPS; Radio Shark; OBD1; Nostromo Speedpad
            Audio: Audigy 2 NX; Clarion 500.5 amp; 100.2 center channel amp; Kicker Solo-baric L7 10" Sub
            Display: Lilliput 7" Touchscreen

            Comment


            • #7
              The recipt from Vineet Singh seems to work on my IBM Thinkpad R60 (2006). When I connect an external mouse, I can now wake up the laptop by clicking on the mouse, but not my touching the internal touchpad. This is however not that important, as what I want is to have the ability to wake up the laptop by touching my Lilliput-touchscreen (Haven't tried that again yet, but guess it will work as it is connected by USB).

              But why is it that I have to make a new key and a new DWORD to get this to work on this computer, while on my girlfriends "old" HP laptop it works "right out of the box" also when touching the internal touchpad.

              I have described this in this post: http://www.mp3car.com/vbulletin/lapt...uchscreen.html

              Anyone have a good explanation on this?

              Comment


              • #8
                Originally posted by popztarr View Post
                The recipt from Vineet Singh seems to work on my IBM Thinkpad R60 (2006). When I connect an external mouse, I can now wake up the laptop by clicking on the mouse, but not my touching the internal touchpad. This is however not that important, as what I want is to have the ability to wake up the laptop by touching my Lilliput-touchscreen (Haven't tried that again yet, but guess it will work as it is connected by USB).

                But why is it that I have to make a new key and a new DWORD to get this to work on this computer, while on my girlfriends "old" HP laptop it works "right out of the box" also when touching the internal touchpad.

                I have described this in this post: http://www.mp3car.com/vbulletin/lapt...uchscreen.html

                Anyone have a good explanation on this?
                Anyone with a good explanation? Seems mysterious that this works right out of the box on some comupters but not on others...

                Comment


                • #9
                  don't touch it
                  or it accidentally goes off with all the p0rn in it while you're having sex in the car?

                  Comment


                  • #10
                    Do you know if your system is going into Sleep S1 or full on S3 state? S1 leaves some things running, S3 is a much deeper sleep (and S4 is hibernate). Check your BIOS settings and make sure that turning on via mouse/key click is disabled. ACPI should be on in bios, and your "computer" device in device manager should have the word ACPI in it, not "standard PC".

                    To get the powermanagement checkbox to appear in device manager for USB devices (that support it), you have to do some registry editing. I'm not responsible if your computer messes up, but it worked for me. Make a system restore point if you are worried.

                    Start, Run, type in regedit and press enter.
                    Go to HKLM\SYSTEM\CurrentControlSet\Services
                    Look for a key named USB or usb. If it's not there, create it.
                    Add a DWORD with the name USBBIOSx inside that key, and give it a value of 0 (it should show up as 0x00000000)

                    Reboot, and you should have the checkboxes in device manager, for your USB devices that you are looking for. It might be under the mouse too, depending on your touchscreen driver.

                    If the powermanagement tab doesn't show up, uninstall your USB devices (from device manager) and unplug them, then reboot. Once XP is back up, plug them in, and it should appear.

                    To change your sleep state when a standby event is called upon, you can use a microsoft tool called dumppo.exe

                    http://www.mp3car.com/vbulletin/lapt...uchscreen.html
                    save to your windows directory.

                    Open a DOS window (Start, Run, CMD, enter),
                    type:
                    dumppo admin

                    And it will show you what state it's set to go to. If it's S3, and you want S1 to resolve an issue or hang like I did, you can then type:

                    dumppo admin minsleep=S1

                    And it will force S1 from that point on.
                    Bump.

                    This information really should be put in a sticky or a wiki or something. Not only to disable the TS from waking up the machine, but to enable it. I have been trying to figure this out for a while.

                    Comment

                    Working...
                    X