Announcement

Collapse
No announcement yet.

DWW-700 problems, no tech support response yet

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DWW-700 problems, no tech support response yet

    I bought the DWW-700 from digitalww.com about a year ago and it has been having problems for a little while now. The screen still looks fine, but the touchscreen won't calibrate correctly. It recognizes that i have touched the screen, but no matter where i touch it, the cursor jumps up to the top right corner of the screen.

    I have tried calibrating the screen several times. I have even tried uninstalling and reinstalling the drivers. Nothing has worked so far. I sent 3 emails to digitalww tech support so far over the course of MANY days, and he has not responded at all.

    Anyone run into this before? Does anyone have any suggestions?


    Thanks,
    Sean

  • #2
    Try the drivers listed on this page: http://www.mp3car.com/vbulletin/show...hlight=DWW-700


    as per Digital WW's response, look here:
    http://www.mp3car.com/wiki/index.php/Where_is_Armen%3F
    <[[][][][][][][][][][][][]>
    Progress:99% not 100% because theres always something to do...
    Centrafuse on XP (lited)
    EN15000
    120GB 2.5" SATA HD
    1GB DDR2 Ram
    M2-ATX PS
    Slot-Load DVD
    BU-353 GPS w/Mappoint 2k6
    DWW-700M

    Comment


    • #3
      Check if your touchscreen isn't pressed by something in the corner.

      Slide a piece of paper between the screen and the housing or open up the screen, clean out any dirt or dust and re-assemble.

      Good luck!
      List of front-ends/usefull apps
      XTroniC | XTroniC Direct

      Comment


      • #4
        Originally posted by sregger View Post
        I bought the DWW-700 from digitalww.com about a year ago and it has been having problems for a little while now.

        I sent 3 emails to digitalww tech support so far over the course of MANY days, and he has not responded at all.

        I would like to share my experience about digitalworldwide.com with you folks. Armen doesnt reply back to his emails despite me a very potential customer. Heck I have even a paypal account infront of me ready to make payment and yet he refuses to reply nor answer my questions.

        Some service!

        Comment


        • #5
          You'll find that a number of members here will disagree with you, myself included.

          Have you sent another email? Have you called him on the phone? How long have you waited for a response?
          Have you looked in the FAQ yet?
          How about the Wiki?



          Under normal circumstances, a signature would go here.

          Comment


          • #6
            I'm experiencing the same issue as the OP. I've been chasing this issue since I bought my DWW-700H also about a year ago. Back in june, Armen sent me a new TS to try out, but it seems that's not the cause since both TS's have the same issue. It must be the controller board (It's not the software/driver).

            I've been trying to get a hold of Armen since October regarding an RMA of the TS controller (or the whole monitor) via email, but have had no luck. I'll probably try calling him next.

            I'd hate to have to pay for it, but it might be easier, so does anyone have a TS controller for sale?

            CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

            Comment


            • #7
              There was a post a long time ago that said the plastic casing was pressing against the screen, causing the behavior you two are experiencing.

              My experience with the 700H has been pretty good overall. I did however have an issue getting in touch with Armen which was frustrating but I will admit that he did do his best considering he is running such a small operation.

              Ill try to find the thread on the casing...

              EDIT:
              http://www.mp3car.com/vbulletin/show...64&postcount=4
              B Smoov
              Project Status: 90% Complete

              Next Step: TIVO for Radio

              Ampie Case :: MII10000 Mobo :: M1-ATX PSU :: 512MB RAM :: 2.5" HD, 60GB, 5400rpm, 16MB Buffer :: DWW-700H :: Centrafuse

              Comment


              • #8
                Thanks for the link. I remember seeing that and trying it out myself, but to no avail. Well, I suppose I could see for sure by pulling the screen out of the case and running it on the bench to see if I can get it working. If that's the case, I'll figure out something. Otherwise, I think I'll need a new TS controller..

                CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

                Comment


                • #9
                  Originally posted by DarquePervert View Post
                  You'll find that a number of members here will disagree with you, myself included.

                  Have you sent another email? Have you called him on the phone? How long have you waited for a response?

                  Well honestly speaking, I have send countless emails to him. Put it like say 7-10 emails per day til one reply comes back. Even now, when I send out one email about 2 weeks back, there has been no reply since. Yes I agree that he is sincere in helping when he do reply. But if such replies comes like 7-10 days, it best to seek elsewhere. No offence guys! Maybe it just that I'm overseas and it's frustrating.

                  Another thing - his contact number refused to accept unknown numbers which if you dial from overseas, thet's what it shows.

                  Comment


                  • #10
                    Work has been nuts lately, so i haven't gotten a chance to try the drivers linked here yet - but thank you for the advice. I will be looking into the casing issue soon as well.

                    My biggest concern with Armen not responding to me (still no response to any of my 4-5 emails) is that when i started emailing him weeks ago, my screen was still under warranty. Now the warranty has ran out due to lack of reply. I didn't see his phone number on the site, can anyone post that?

                    As of this morning, the website wasn't pulling up for me either. I am fully willing to give people the benefit of the doubt, but after awhile you have to accept that you have been screwed.

                    -Sean

                    Comment


                    • #11
                      I will give him the benefit of the doubt that he is a busy guy, but I still haven't gotten a reply to any of my emails. We are talking 2 months now with no reply. The part that bothers me is that when I first tried to contact him, my screen was under warranty, and now it no longer is. I don't want to eat the cost of a new screen because of a tardy reply.

                      I couldn't find his phone number on the site (old site and new). Does anyone else have that number? If so could you either post it or PM it to me? Thanks.

                      Comment


                      • #12
                        I have tried to post this 3 times now this week and i guess it hasn't been approved because it isn't showing up....

                        Anyway, i still haven't received a reply from Armen to any of my emails after about 2 months of waiting. The part that i am the most concerned with is the fact that when i first contacted him, my screen was under warranty. Now that i haven't gotten a reply in so long, it's no longer under warranty. I don't think that's fair.

                        I would try calling him but i couldn't find his number on his website (new or old). If anyone has that number would they mind PMing it to me so i can try giving him a call?

                        I trust what you guy say about him, and give him the benefit of the doubt, but 2 months is getting unreasonable.

                        Comment


                        • #13
                          i appologize about the triple post guys, they weren't showing up for me so i tried again, then they all appeared at once. if a moderator wants to deleter two of them, go for it.

                          Comment


                          • #14
                            Email me today ([email protected]) and I will take care of this issue. I apologize for the delay.

                            Armen

                            Originally posted by sregger View Post
                            I have tried to post this 3 times now this week and i guess it hasn't been approved because it isn't showing up....

                            Anyway, i still haven't received a reply from Armen to any of my emails after about 2 months of waiting. The part that i am the most concerned with is the fact that when i first contacted him, my screen was under warranty. Now that i haven't gotten a reply in so long, it's no longer under warranty. I don't think that's fair.

                            I would try calling him but i couldn't find his number on his website (new or old). If anyone has that number would they mind PMing it to me so i can try giving him a call?

                            I trust what you guy say about him, and give him the benefit of the doubt, but 2 months is getting unreasonable.
                            http://www.digitalww.com

                            Comment


                            • #15
                              I wanted to make an update post and let you guys know that Armen did in fact take care of me. I shipped it off to him and he promptly shipped it back all fixed. Thank you Armen for fixing my screen.

                              Comment

                              Working...
                              X