No announcement yet.

Lights light up, but nothing more

  • Filter
  • Time
  • Show
Clear All
new posts

  • Lights light up, but nothing more


    I bought a 7" in dash TFT from Ebay. This one

    I connected it to my ATX PSU and when I turn on my carpc the buttons light up, but then it goes black and nothing more happens.

    I tried pulling the screen out of the chassis and then powering it, now the motor just pulls the screen back in and then goes black again..

    Any ideas, what to try?

    Sorry for my ba(a)d english....

    No one who has a suggestion to the problem?

  • #2
    So, has it worked before? Or has it been doing this from the beginning? You might have to change the resolution in your BIOS to work with that monitor. If thats not the case, the backlight inverter could be bad, or the ribbon cable could be loose..


    • #3
      How did you power it off the power supply.

      This is the important information.

      did you connect the ignition wire to?
      Fusion Brain Version 6 Released!
      1.9in x 2.9in -- 47mm x 73mm
      30 Digital Outputs -- Directly drive a relay
      15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
      Buy now in the Store