Announcement

Collapse
No announcement yet.

DWW-750FM problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DWW-750FM problem

    I purchased the DWW-750FM last September, and when I got into my car today, and started it up, the LCD reads on the front of the display (not the screen) the unit reads "M 1234". I can't turn it off or on, and the screen doesn't come on. When I turn the car off, the buttons stay illuminated, which is not typical. Has anyone else gotten this?

  • #2
    I had similar issues with mine. I ended up disconnecting the unit from the power supply (ie: dissasemble the dash, unplug it in the back, put everything back) and that would reset it. It happened several times to me starting in january or so. Eventually, even resetting it wouldn't work so I sent it back to Armen. His testing of it indicated that it still worked, however he is sending me a new one back just to be safe. Since it wouldn't reset when i sent it off to him, and it worked when he got it, I suspect over the shipping time it had a capacitor in it that held the corrupt code inside that discharged, then it reset itself. So when I get it back, I am installing a switch in my dash to disconnect it from power without taking the dash all appart. BTW, pulling the radio fuse doesn't work to reset it since it is also connected to the clock power. I hope this doesn't scare you, because I really do find this to be an excellent radio/screen & the above only happened to me very rarely.
    2001 PT Cuiser
    VoomPC with 1.5Ghz C7
    M2 power supply
    in dash slim tray dvd drive
    DWW-750FM c/w 7" USB touchscreen,AM/FM, 4x45W amp
    See my install here

    Comment


    • #3
      Ugh.

      That stinks. I have a plug on my fuse box that seems to disconnect everything (even the clock), so hopefully if I unplug it long enough it will take care of it. My dash probably can only take being taken off a few more times before stuff starts breaking . Thanks for the help.

      Comment


      • #4
        That did it.

        That did it. Thanks a ton. Hopefully it will be a while before it creeps back up.

        Comment


        • #5
          Guess Not

          Wow, I think this unit is self-destructing from the inside . It is showing some very strange behavior, which seems random and inconsistent. When I turn it on, I can see VGA, but no mouse control. The amp kicks in an out on Radio. The blue light on the volume knob stays on even when switched off, etc. I'm hoping I can reproduce some of these issues so I at least can figure out whats wrong with it....

          Comment

          Working...
          X