Announcement

Collapse
No announcement yet.

[SOLVED] help, my screen wont turn on!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] help, my screen wont turn on!

    ok.. here's the deal, I was going to mount my screen this weekend with some fiberglass and so on so I removed everything from the front part of it... being sure that I noticed where everything was going...

    Today I put it all together again, had some problem with the biggest of the flat cables but it finally got there to, now when I was putting it back in the car the power buttons seems to have stopped working, there's a red light that usually turn blue when I turn the screen on but nothing happends... I can hear the small "clicking" sound when I press the button so it's at the right place, took it apart one more time and all the cables are connected... any ideas!

    btw, it's kind of a noname screen but it looks like this:
    Swedish site for CarPC's
    http://www.bilpc.info

  • #2
    Sound like lilliput infamous button board problem. Connector and cable isn't line up correctly.
    BTW, that screen look like a lilliput.
    Take the ribbon cable out of the button board and slide it to the left when insert. If it doesn't work, move it to the right. If that still doesn't work, some other problem.
    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
    89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
    Y2K Accord Dell GX150
    RoadRunner is the best FE PERIOD
    EmoRebellion is a SCAMMER

    Comment


    • #3
      Originally posted by MatrixPC View Post
      Sound like lilliput infamous button board problem. Connector and cable isn't line up correctly.
      BTW, that screen look like a lilliput.
      Take the ribbon cable out of the button board and slide it to the left when insert. If it doesn't work, move it to the right. If that still doesn't work, some other problem.
      Thanks, I ran out quick this morning hoping it would help but no... still only the red light! I tried to see and the cable looks aligned with the connectors inside it!

      As I said I was having some problems getting the other cable getting connected, it's twice as wide as the one from the buttons, have no clue how that little white plastic part is supposed to hold it, and now when I removed and checked again some of the "wires" looked bent at the end, can I just take a scissor and cut away 1-2 mm of it...

      if it looks like a lilliput it might work the same way to... isn't there anyway to "bypass" the power-on button so that it turns on when I turn on the ignition... that might work!
      Swedish site for CarPC's
      http://www.bilpc.info

      Comment


      • #4
        So, been trying a lot this morning, tried every position of the button cable that I could think of but it still only gives me the red light, cut away the part of the wider cable that looked bad and attached it again, still no go...
        by now I have re attached all the cables a multiple times but it just wont give me the blue power on light...

        as I thought it might be the button I even dug up the remote but that didn't help either! I'm getting real sad and frustrated right now since I need my comp for work and I don't have the spare money to get a new screen!

        Read about 2 ways of getting atleast a lilliput to start with the ignition, I'm not that good as soldering and I don't want to mess it up even more and for the other solution I need the screen to be on!

        any other ideas or am I the only one that have had this problem!
        Swedish site for CarPC's
        http://www.bilpc.info

        Comment


        • #5
          Guessing it's a Lilliput 7" VGA Touchscreen 629GL-70NP...

          Have you tried auto power on :
          http://www.mp3car.com/vbulletin/lcd-...ing-guide.html
          ----------------------------------------------------------------------

          Comment


          • #6
            Originally posted by almera View Post
            Guessing it's a Lilliput 7" VGA Touchscreen 629GL-70NP...

            Have you tried auto power on :
            http://www.mp3car.com/vbulletin/lcd-...ing-guide.html
            No idea if it's a lilliput or not... doesn't say anything abour brand on it... as soon as I get the screen to start up again I'm gonna try that one... but right now I only get the red light as stated above!
            Swedish site for CarPC's
            http://www.bilpc.info

            Comment


            • #7
              Take a picture of the controller board and the lcd panel and post it here. Some may recognize it.
              2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
              89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
              Y2K Accord Dell GX150
              RoadRunner is the best FE PERIOD
              EmoRebellion is a SCAMMER

              Comment


              • #8
                ok, here are some shots of the inside of my screen... I'm getting really frustrated here so any suggestions are welcome.





                Swedish site for CarPC's
                http://www.bilpc.info

                Comment


                • #9
                  so I guess no one have any more suggestions what might be wrong... the screen isnt dead since it shows a red light... it just wont turn on!
                  Swedish site for CarPC's
                  http://www.bilpc.info

                  Comment


                  • #10
                    Unfortunately I have a dead monitor as same issue. I have replaced ribbon cables, even new LCD panel but no go. That was because of controller board failure. Sorry that I can't help more..
                    ----------------------------------------------------------------------

                    Comment


                    • #11
                      Originally posted by almera View Post
                      Unfortunately I have a dead monitor as same issue. I have replaced ribbon cables, even new LCD panel but no go. That was because of controller board failure. Sorry that I can't help more..
                      with controller board do u mean the board with the buttons on it or some other board in the screen... I don't know if there's anyway to get some replacement parts but I could give it a try...

                      Anyone recognize the screen, interested in knowing if it might be a lilliput without the label, then the "auto-on" hack might work!
                      Swedish site for CarPC's
                      http://www.bilpc.info

                      Comment


                      • #12
                        That was the VGA controller board, like this (that's for Lilliput 619 monitor):
                        Attached Files
                        ----------------------------------------------------------------------

                        Comment


                        • #13
                          Originally posted by almera View Post
                          That was the VGA controller board, like this (that's for Lilliput 619 monitor):
                          ok thanks, going to rip that part out then and see if I can find anything that doesn't look right, will post a pic of that to if it might help ppl knowing what kind of monitor it is!
                          Swedish site for CarPC's
                          http://www.bilpc.info

                          Comment


                          • #14
                            Too bad you voided your warranty by tearing into it. Stick it back together and try to exchange it. I doubt the damage was done by you. These things are notorious for random failures and I doubt you will be able to see whats wrong with it.

                            Comment


                            • #15
                              Originally posted by Hindmost View Post
                              Too bad you voided your warranty by tearing into it. Stick it back together and try to exchange it. I doubt the damage was done by you. These things are notorious for random failures and I doubt you will be able to see whats wrong with it.
                              could probably have done that if it wasnt the small problem that I have mounted it to some pieces from my dash with fiberglass and all...

                              Was thinking of buying one more exactly the same, carefully getting the pieces out of the new one and putting in the ones from this one and then sending that one back saying it didn't work when I got it... only problem with that is that I don't have 250$ more to spend on a screen...

                              well here's the pics from the controllerboard anyway if it might give someone a clue what kind of screen it is:



                              Swedish site for CarPC's
                              http://www.bilpc.info

                              Comment

                              Working...
                              X