No announcement yet.

Help Please, no display on Lilliput EBY701

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help Please, no display on Lilliput EBY701

    I have the lilliput EBY701. My problem is that I'm not getting any display. I searched and found this thread, .

    Like that guy, I'm not even getting the "no signal" text on my screen, no light. They suggested that it was the inverter or cable ribbon. I did opened up my lilliput to do some fabrication into my dash. However, I managed to take off the front face without removing any ribbons, so I don't think it's the ribbons. I mean, it worked after I closed the case. I also did the auto-power-on mod to my lilliput before it messed up. Now once I plug in the power, all the blue lights flashed quickly once (a split second, a lot faster then normal) and then the power button flickers red infinitely. Once in a while, it remains red.

    I pressed all the buttons, fiddled with my remote; nothing improved.

    << extra information follows >>

    I recently just brought all of my carputer parts within the last 2 weeks. I have the M10000 motherboard with the lilliput eby701. I'm powering the computer with a laptop power supply and the lilliput with the supplied ac/dc wall outlet.

    I installed windows xp and hooked up the lilliput and everything was displaying fine. I installed the video driver and rebooted. I ended up with a bunch of horizontal lines. I then installed the touch screen driver the next day and it worked. I was playing with the touch screen and next thing I know, the screen turned black and wasn't able to get a display again.

    I hooked the computer to a crt and it works fine with the horizonal lines. I did a flash of the bios and updated video drivers, pictures are perfect on the crt now. Hooked back the lilliput, no display.

    << extra information ends >>

    Please help. I'm (-) this close to buying another one. I opened it up to look for loose ribbons, tried to pushed them tighter (I haven't removed the ribbons and placed them back again yet).

    Sorry for the long post, thanks in advance for any helps.

  • #2
    Here's a screen shot of the board. Could anyone see if something's fried? Or if I have a nano fuse, where is it?


    • #3
      I also have the same problem and i've never even open mine up....??? tryin to contact Lilliput uk but no answer on the phone so i'll try agen tomora mornin


      • #4
        I'm having a similar problem. You ever resolve it?
        Ashley -
        Check out my car club.


        • #5
          Not to state the obvious here, but have you checked the "screww together" connection in the vga cable?

          A couple guys have had this problem and found that the connector was not completely tightened or wasn't making proper contact.

          Check it out.................
          For once you have tasted flight you will walk the earth with your eyes turned skywards, for there you have been and there you will long to return.
          Leonardo Da Vinci


          • #6
            My problem is solved. It's not what I thought. Voltage was hooked to the 5v rail not 12v. DOH!!!
            Ashley -
            Check out my car club.