Announcement

Collapse
No announcement yet.

Lilliput 629GL Problem: Touchscreen unresponsive

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lilliput 629GL Problem: Touchscreen unresponsive

    Hi,

    I am having fairly severe issues with my new Lilliput 629GL 7" Touchscreen. The touch input has recently failed and is unresponsive on both my CarPC and my laptop. I have searched the forums here for weeks without success, reinstalled the drivers several times, and checked the continuity of the 4-wire ribbon cable. The VGA display
    works fine, but the touchscreen utility on the taskbar doesn't show any controllers when the USB cable is plugged in. Windows hardware profile also doesn't show the driver under the Mice tree.

    Could the problem be a severed connection in the unified connector plugged into the 629GL? Is there a reference available for the pin diagrams associated with the USB, VGA, Mini-DIN, RCA, and Lilliput connectors?

    Here is a thread documenting a similar symptom, but the associated remedy produced no result for me.
    http://www.mp3car.com/vbulletin/lcd-...t-problem.html

    Thank you kindly.

    Mujahid

  • #2
    I checked the pin connection between the USB plug and the Centronics 14-in connector and it appears that the +5V USB pin is not connected to any of the Centronics pins. The ground, D+, and D- pins are connected to the 11, 8, and 6 pins, respectively.

    Is my connector faulty or is it normal to disconnect the +5V pin? There is a gray wire from one of the bundles coming from the Mini-din that is obviously disconnected, but I assumed this is simply an extra wire from a stock part.

    Bogusness prevails. Any suggestions?

    Comment


    • #3
      I had a problem simillar to yours with my 619. XP would say "unknown USB device" and of course TS would not work. I reloaded drivers, replaced the TS panel and the controller and neither one fixed the problem. I finally discovered that there was no connectivity between the round connector and the USB plug for one of the pins. I don't remember which one but it was one of the middle pins in the USB plug. I bought a VGA extenstion cable and a USB cable. Cut the ends off of both and soldered them to the 619 board in place of the old cable. Now everything works beautifuly.
      Compaq Evo D510 e-PC - P4 2.0 - 512M RAM - 120G 3.5 HD - 7" Xenarc 700TSV - DSATX fitted nicely inside the PC case

      Comment


      • #4
        Thanks Zebelkhan. I am tracing each of the pins on the USB and VGA to the centronics connector and the +5V from the USB is not connected to any of the 14 pins. The connector is probably faulty, but I can make a replacement easily, provided I have the correct pinouts.

        Have you (or anyone) succeeded in taking apart the centronics connector gracefully?

        Otherwise, do you know which centronics pin should be connected to the USB +V?

        The 26 pin diagram shows connectivity:
        [media]http://www.mp3car.com/vbulletin/attachments/lcd-display/21185d1130686331-faq-everything-you-need-know-about-your-lilliput-lilliput-cable-pin-wiring.jpg[/media]
        From this thread:
        http://www.mp3car.com/vbulletin/lcd-...illiput-3.html

        But I cannot find a similar pinout for the 14-pin 629GL.

        Thank you!

        Comment


        • #5
          Apparently this problem is not unique:
          http://www.mp3car.com/vbulletin/lcd-...n-problem.html

          I took apart the Centronics 14-pin connector and mapped the pins between the VGA, RCA(3), USB, and Mini-Din connectors. Bizarrely, I can account for all pins except for the USB +5V pin and the corresponding Mini-Din pin. Perhaps the USB power is not required, as I had originally believed. The other 3 USB pins (+D,-D,GND) are continuous from the USB plug to the Centronics connector.

          So my beige unifying connector appears to be functioning properly, but I still get the "Unknown USB Device" error in Windows. I'm unsure where to continue troubleshooting.

          Thank you for any suggestions.

          Comment


          • #6
            Project240,

            Have gotten anywhere?

            I'm having very similar problems, the only differences are that I dont get a "USB device Unknown" error, I don't get any errors, I installed various version of the xp/vista touchkit utility/drivers and they all seem to install ok, but once installed, and despite much of my efforts I could not get the touchsreen to respond, even during calibration.

            My Lilliput has the same 14 pin centronics cable, and I also noticed that USB Vcc was not present on the 14 pin connector. In fact, since there were 3 wires between the 9 pin and the 14pin, I figured they were 3 conductor shielded wires and I couldn't accept why I wasn't getting continuity for that lead. So I opened everything up and found that the 9th wire (pin 3 on the 9-pin to the centronics connector). But I found that there was a red-insulated conductor in one of the wires that was in fact clearly left disconnected on both ends, and all connections on the 14-pin were in tact. Only 9 pins are used on the male 9-pin connector. I whipped up a Pinout, since I didn't see one in here.

            Unfortunately my monitor is a Transflective modified FA841-NP/C/T with a upgrade to a Fujitsu USB panel and controller (anti glare) [Motorcity], so I don't know how much similarity there is really. And I'm going to have to start my own thread about some of the other problems I'm having.

            BTW, do you know what the black plug is for?
            I found it odd that it was connected to 2 pins like ground, leading me to think it's power supply-ish, which got me into thinking about USB Vcc... I didn't get a manual, so I wasn't sure. And there is another power plug on the board on my screen, next to the 14 pin female.

            It's been a while...

            Comment


            • #7
              h3rk,

              Unfortunately my problem persists. This issue has tremendously degraded my installation progress. I am unsure how to proceed, except invoking the warranty or buying a new screen/touchpanel.

              Thanks for the pinout, I was planning on posting one, but your diagram looks fantastic.

              The black plug is power and can be used with the AC adapter (or 12V) to power the monitor. I have been using mine this way, rather than using the one next to the centronics connector.

              Best of luck solving your issue, I will post any progress or results.

              Comment


              • #8
                Originally posted by Project240 View Post
                Perhaps the USB power is not required, as I had originally believed. The other 3 USB pins (+D,-D,GND) are continuous from the USB plug to the Centronics connector.
                Unfortunately I am not familliar with the new 629 as mine was a 619 and it had a 9 pin barrel plug rather than a Centronics connector. But I am thinking unless the TS controller is part of the main board (I heard that maybe true on the new 629), it has to get power from somewhere. If the TS controller is a separate board, as it was in the 619, then that disconnected wire maybe the issue. On my 619 I had a separate TS controller which was independent of the main board so I soldered a separate USB cable to it and that solved the problem. However, in my case, I did not see any wires that were left disconnected. One simply did not have continuity so I assuemed there was break somewhere.

                Sorry I cannot be of help here!
                Compaq Evo D510 e-PC - P4 2.0 - 512M RAM - 120G 3.5 HD - 7" Xenarc 700TSV - DSATX fitted nicely inside the PC case

                Comment


                • #9
                  You guys are correct, the 5v is not connected because the device is powered externally. Here's my pinout if you still need it...
                  14 pin Proprietary pinout

                  Comment

                  Working...
                  X