Announcement

Collapse
No announcement yet.

New Lilliput White Screen of Death. Maybe.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Lilliput White Screen of Death. Maybe.

    I just bought an 8" 809GL-80NP/C/T, turned it on and it worked beautiful for about 15 minutes. Then the screen goes completely white. The white will fade out to black stripes after about 2 minutes, the screen will kick off then it will come back on and start working again for about 2 more minutes. When it does it again, it seems to loose power to the LCD. Turning it off and on doesn't help, but the buttons still light up blue. If I wait it will come back on and work for a few minutes before repeating the process.

    I have also noticed after the screen goes wacky and comes back, if I hit the menu button, the menu colors are off like red and green, its also granulated. However the VGA picture in the background looks fine.

    I saw in another post where someone place a jumper wire over a fuse on the controller baord, but the picture they posted doesn't come up anymore for me to try it.

    Any thoughts would be greatly appreciated.

  • #2
    Sounds like the ribbon cable might be loose on the LCD
    My BMW E46 carpc
    My iGuidance 4 skin
    FS transflective 2008 lilliput

    Comment


    • #3
      Wow quick reply thanks. However, I have already disassembled the LCD and am sure all ribbon cables are securely plugged in...

      Comment


      • #4
        I think its the resolution causing the problem because I just watched an hour dvd through the RCA and no hiccups. I have my pc resolution set to 640x480 with a refresh rate of 70hz. Is this not right?

        Comment


        • #5
          Scratch that comment. Tried another test same result in less than 5 min. Whats going on here?

          Comment


          • #6
            Guys this is really taking a toll on me. I have uploaded a video of some of the things its doing. It actually worked for longer than normal.

            Also, the site seemed to speed up the video... Anyhow, please watch and post any suggestions. Thanks..

            http://www.veoh.com/videoDetails.htm...472350EYrGeQBK

            Comment


            • #7
              Noone has any pointers eh?

              Comment


              • #8
                It is the ribbon cable

                If you havent opened it, RMA it. Once you open it, it is yours forever.

                It is a 5 second fix if the case will be opnened. THere is a 25 conductor ribbon cable and a little itty bitty zif socket. If it is loose, or not perfectly straight, you get the white screen of death.

                So I suggest RMAing it to get a new screen because if that ZIF socket is broken or not repairable, they you will be S.O.L.
                Fusion Brain Version 6 Released!
                1.9in x 2.9in -- 47mm x 73mm
                30 Digital Outputs -- Directly drive a relay
                15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
                Buy now in the MP3Car.com Store

                Comment


                • #9
                  Well it was ebayed. And yes it has already been apart. Im sure all the cables are tightly secured.

                  Comment


                  • #10
                    I just took it apart again. Made sure the cable's arnt loose at all. I did take the time to count the pins on the ribbon cables.

                    On one, its a 13pin that connects to the controller board "menu power etc"

                    The other is like 50 pins, far past 25.

                    Comment

                    Working...
                    X