No announcement yet.

Xenarc 700TS controller not detected

  • Filter
  • Time
  • Show
Clear All
new posts

  • Xenarc 700TS controller not detected

    My Xenarc 700TS has worked perfectly for the past 1.5 years or so. Last week (just before a long road trip of course) it stopped working normally.

    First, it detected constant touch and the calibration was completely off. So I ran a calibration with a mouse, and it sat at "Reading Parameters" for a long time before quitting. I uninstalled the drivers and tried reinstalling the latest (4.6) driver and now it doesn't detect the controller.

    I looked at the back panel (it's open, as the screen is epoxied into my dash) and saw that the mini-board highlighted in the pic below (I stole this pic from another thread) is no longer glued to the board. Moving it causes the little green LED on the board to turn on and off. Does this light indicate that it's working? The plugs are all tight and well connected as far as I can see.

    Any ideas? I hate controlling my carpc with a mouse...
    Attached Files