Announcement

Collapse
No announcement yet.

lilliput problem please help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • lilliput problem please help

    I bought a lilliput 619 off of the classifieds but only half of the screen works because of a torn ribbon cable! Can it be fixed? Here are some pictures




  • #2
    Anyone!!! can that cable be replaced?

    Comment


    • #3
      I sold this monitor to Ethan5327 and i'm sure it worked perfectly. The pictures below where taken on August 6th and the monitor shipped out August 7th. Damage definitely did not happen during shipping since it was well packed.

      Iím really sorry but I'm sure that kind of damage was due to your handling of the monitor. I'm not sure how much experience you have with these monitor but everyone know they are pretty fragile and should be handled with care when out of the casing.






      Comment


      • #4
        How the screen looked when I recieved it:

        Comment


        • #5
          I dont know if DigitalWW is still in business but he had replacement ribbon cables. And I just saw a thread on here a few days ago with a source for new ones also so give that a shot too.


          Here is the link (please pay me $5.00 for finding it for you)

          http://www.mp3car.com/vbulletin/lcd-...cd-ribbon.html
          '02 GTI
          [Routis '04] [Opus 90W] [160GB Maxtor HD]
          [Lilliput 7" TS] [VIA M10000] [XMPCR]
          [512MB RAM] [Custom housing]
          [Deluo GPS Mouse] [E-MU 0404 Soundcard]
          Progress Meter: [==============|] 99.9%

          Comment


          • #6
            I would consider the $5 but that is the wrong cable I don't think the torn cable can be removed or replaced so I'm out $130

            Comment


            • #7
              Post a pic of the ribbon cable. Maybe someone has a spare, dont sound so mopey and down. And talk to Armen Im sure he has other available if he is still around.
              '02 GTI
              [Routis '04] [Opus 90W] [160GB Maxtor HD]
              [Lilliput 7" TS] [VIA M10000] [XMPCR]
              [512MB RAM] [Custom housing]
              [Deluo GPS Mouse] [E-MU 0404 Soundcard]
              Progress Meter: [==============|] 99.9%

              Comment


              • #8
                You could also try contacting Lilliput directly. See if they could supply the part.
                03 Accord Sedan CarPC

                Comment


                • #9
                  I cant see anyway to disconnect the cable from either side so I don't think it can be replaced I am also in MA so blackcobra if you think you could fix it I would pay you to fix it

                  Comment


                  • #10
                    I MAY be able to help, but I'm usually not comfortable messing with someone else's equipment. In this case, I would be more willing to try, (seeing how I don't think I could make it worse.) but I won't promise anything. If you could post some good close up pictures of what I would be working with, I'll think about giving it a shot. Where in MA are you? I'm in West Springfield.
                    03 Accord Sedan CarPC

                    Comment


                    • #11
                      Im in framingham pictures are comming soon

                      Comment


                      • #12
                        The ribbons should come out, there is a little weird clamp that holds them down, usually a really small screwdriver will do the job. Search for some people that have taken their lilliputs out of the plastic and placed them into their own custom housing. A guy named PHC (if I remember correctly) had a GREAT write up on the process. But he also later changed his screen name to Megatronic or something.... Just do a good search and you'll find plenty of pictures. All is definitely not lost, just a little more work than you planned on... But thats all part of the hobby.... trust me.
                        '02 GTI
                        [Routis '04] [Opus 90W] [160GB Maxtor HD]
                        [Lilliput 7" TS] [VIA M10000] [XMPCR]
                        [512MB RAM] [Custom housing]
                        [Deluo GPS Mouse] [E-MU 0404 Soundcard]
                        Progress Meter: [==============|] 99.9%

                        Comment


                        • #13
                          It looks to me that the cables connect the board directly to the screen here are some pictures

                          http://api.photoshop.com/home_0a8854...84a42c16ea1840

                          http://api.photoshop.com/home_0a8854...00ef2f936a525f

                          Thanks in advance for your help

                          Comment


                          • #14
                            Oh, damn. That's the ribbon from the LCD board to the LCD itself. That would be difficult. It is still a cable, meaning it comes off the PCB SOMEHOW. It may be soldered on there. I know I used to be pretty crafty with an iron back in high school, but I don't have an iron with a tip that could do something like that.

                            After looking at the pictures, a question does come up. What made the LCD come off of the backlight housing like that.

                            Edit: See all these little lines (circled to help point them out), where does the other end of this cable go?
                            03 Accord Sedan CarPC

                            Comment


                            • #15
                              I pulled the cable out / tore it off you can see where the other end goes in the second picture of my last post Anyway does anyone have a 7 inch touch screen that they want to sell me I don't even need the touch part or controler board if it is a lilliput

                              Comment

                              Working...
                              X