No announcement yet.

Xenarc TS acting very strangely

  • Filter
  • Time
  • Show
Clear All
new posts

  • Xenarc TS acting very strangely

    My Xenarc touchscreen has started sporadically doing something that is hard to describe. It sort of anchors the cursor to a point on the screen so that when I touch anywhere else, the cursor drags (as if the right mouse button were down) to the point I am touching. When I take the pressure off this point, the cursor immediately pulls back to the position at which it was anchored. I guess that sometimes the fact that I have stopped touching the screen does not register. Also, sometimes it simply clicks itself, but this is more rare.

    I attempted to make a video of this phenomenon with my low-quality camera phone, but it didn't come out very clear. I'll put it up anyway, and maybe you'll be able to see what I'm talking about. You can see the mouse cursor running to and from my finger when it does "anchor" itself (which it does several times in the video).

    Anyway, any ideas? I tried the method in the "how to fix your disfunctional touch panel" sticky and it didn't seem to work.

  • #2
    most likely the casing is pressing too hard against the overlay, try taking out the casing and see if problem persist.


    • #3
      I tried the method in the "how to fix your disfunctional touch panel" sticky


      • #4
        then its probally time for a new TS overlay.


        • #5
          Already ordered. Will update this post for posterity if/when I confirm that it's the panel.


          • #6
            New touch panel seems to have solved the problem.