No announcement yet.

K301 Touch Function Failed - Any Suggestions?

  • Filter
  • Time
  • Show
Clear All
new posts

  • K301 Touch Function Failed - Any Suggestions?

    I've had a K301 touch screen for about a year now, and the touch function just quit working alltogether. The display still works fine, but the Windows device manager no longer sees the USB connection.

    Does anyone have any suggestions about what to try, to fix it? Or do I just give it up as dead? (I've tried the usual things like unplugging and replugging connectors.)

    Thanks in advance.

  • #2
    do your self a favor and try it on another PC.. usb connections can be messy.


    • #3
      Have you tried the newest egalax driver?
      Have you looked in the FAQ yet?
      How about the Wiki?

      Under normal circumstances, a signature would go here.


      • #4
        Further experimentation shows it's definitely problems in the electronics in the K301 itself. Here's what I've got now:
        • The "Menu" button on the K301 no longer does anything.
        • The "Source" button no longer changes sources, but every 3rd push enables the touchscreen (and the following push disables it again).
        • None of the utilities in TouchKit work any more. (They all die at "Reading Parameters from Controller")

        In short, it looks like the K301's embedded microprocessor has lost its mind.