No announcement yet.

Lilliput won't turn on (sometimes)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Lilliput won't turn on (sometimes)

    Hey guys
    So I'm nearing completion of my project (Right now, it's functional, but not the least bit pretty, haha), but I've run into a minor concern...

    I have a lilliput monitor, it's been mounted in my car for the past 3 months or so, but has only been used once in awhile for the RCA input (plug in my MP3 player and watch movies). I hooked up the computer to it for the first time on Sunday (Excluding when I first got it to make sure it works), and everything worked fine... but recently, I've noticed that it won't turn on.. It's done this to me twice now where it'll flash a red light in the power button and won't display anything. None of the buttons are functional, but the touch screen still works fine (I just can see anything). Both times that I resolved this issue I fixed it by just simply unplugging the data cable off the monitor, wait 5 seconds, then plug it back in and it boots back up no problem.

    This raises a bit of a concern for me though cause I eventually want to fabricate the monitor right into the dash.. Right now it's easy to pull it out and yank the cable, but it might not be down the road. Has anyone else come across this kind of a scenario? It only happens when I start the car.. it doesn't turn off and do that. Turning the car on and off ( or the accessory switch ) doesn't fix it, it'll just do it every time I turn it back on. It's not a noticeable pattern to how many times it flashes, just a consistant red light flashing.

    thanks. Next time this happens I'm gunna take a video of it, case it helps out.

  • #2
    It happened again...


    • #3
      I power mine off of the PSU like you've mentioned however if that doesn't take care of your issues, you may want to put a hard switch between the barrel plug for the lcd and the power source so you can easily simulate unplugging and replugging in the monitor?