Announcement

Collapse
No announcement yet.

Sporadic touchscreen issue - Lilliput 629

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sporadic touchscreen issue - Lilliput 629

    So I bought the 2008 Sunlight readable Lilliput 629 about 3 years ago. It's been working pretty good since then, but probably starting about 1.5-2 years ago, it's been doing a sporadic thing.

    What will happen is you can be touching the screen, and the mouse will suddenly go to the top left corner and stay there no matter where you touch. It will sit there anywhere from 30 seconds to 2 minutes and then the touch will suddenly start working again (the mouse follows your touch). Using a separate mouse is a workaround while it's in this state but obviously not ideal. Currently I'm on Windows 7 x64, but previously I was on WinXP and I think it was doing it on that OS as well. I've updated drivers over the last 2 years and it hasn't made any difference. Calibrating doesn't help, although if you calibrate it while it's in that messed up condition, it will completely hose it up and you'll have to recalibrate it when it's in the working state again.

    Also, when it does happen, and it resolves itself, it doesn't seem to happen again until the computer is shut down and restarted again - only seems to happen once per boot cycle (at some point after it's booted). It sometimes happens within the first minute of seeing the Windows desktop, other times it could be after 5 mins - it really does seem to be random. I've tried reseating the USB cable when the mouse is in the corner but it makes no difference. I've even used a completely different port as well with no difference.

    I thought maybe temperature might be the culprit but it happens any time of the year. I think it's something to do with lilliput but I'm not sure. If it is, I wonder if it's something I can check and possibly fix.
    Last edited by jbradshw; 08-09-2011, 12:40 PM.

  • #2
    Funny thing is I am on here looking for an answer to the very same problem. Mine does not go up to the top left and sit there mine just freezes and i can't move the mouse anywhere with my fingers. I can use a keyboard and or mouse to nav around the screen, but while driving that is nuts. This has happen to me just lil more then 6 months ago. I just replaced the hard drive with a ssd drive thinking that was the problem and doing so i replaced windows xp with windows 7. I am lost, i go to Lilliput's web site http://www.lilliput.com.cn/en/service02.php to download the latest drivers and they don't download. I am confused, should i buy a new monitor?

    Anyway just wondering if you had a fix for this i see no one add any advice that stinks.

    Thank you
    Phil

    Comment


    • #3
      Funny thing is I am on here looking for an answer to the very same problem. Mine does not go up to the top left and sit there mine just freezes and i can't move the mouse anywhere with my fingers. I can use a keyboard and or mouse to nav around the screen, but while driving that is nuts. This has happen to me just lil more then 6 months ago. I just replaced the hard drive with a ssd drive thinking that was the problem and doing so i replaced windows xp with windows 7. I am lost, i go to Lilliput's web site http://www.lilliput.com.cn/en/service02.php to download the latest drivers and they don't download. I am confused, should i buy a new monitor?

      Anyway just wondering if you had a fix for this i see no one add any advice that stinks.

      Thank you
      Phil

      Comment


      • #4
        Try cleaning the screen. I had a similar problem. The mouse would always be clicking this one spot, so I cleaned there and it went away.

        Comment


        • #5
          Hi Bramlet, thank you for the reply, I did clean the screen actually i did that way before i started any of these troubleshooting ideas. I can't believe that the monitor would be bad cus it works once in a while but not every time.

          Phil

          Comment


          • #6
            do either of you have it mounted in a double din frame, or is it mounted in the stock housing.


            usually that indicates that part of the touch panel is getting pinched-- on the double din frame, you just need to play with the 4 screws to keep the screen tight, but not tight enough to cause this issue.
            My OLD 2001 Mitsubishi Eclipse GT:
            "The Project That Never Ended, until it did"


            next project? subaru brz
            carpc undecided

            Comment


            • #7
              Hey Soundman,

              Yes mine is in it's original case, i have had mine for about 4 and half years and up until about 8 months ago everything had been great. Now I just can't get it to work probably anymore.

              Thanks
              Phil

              Comment


              • #8
                well, i believe 4 years is past any warranty period, so you don't have much to loose... i think you might need to open it up and make sure that there is not any dirt or particles stuck between the bezel and the touch panel-- that could also trigger things like this.
                My OLD 2001 Mitsubishi Eclipse GT:
                "The Project That Never Ended, until it did"


                next project? subaru brz
                carpc undecided

                Comment

                Working...
                X