No announcement yet.

Touchscreen not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Touchscreen not working

    Hi everyone,

    I recently installed a car computer in my car with a Fitpc2 and a lilliput 669 gl. It has been working great for the longest time and then it abruptly stopped working. Here is what happened.

    I went to move the FitPC from my glove box to back farther in the glove box to make room to put back the default car manual in the glove box. This was all just to make the whole job clean. Absolutely everything worked before I attempted to move IT! In the process of moving it I had to move the cables around one of the steel supports inside the glovebox. I was having trouble moving the big hulky DVI to HDMI cable to I put some strain on it, just some minor bending and pushing. I then decided to take the bezel off with the screen to get better access to the cord. When taking it off the motherboard got caught on the frame around the bezel and came off of the bracket a bit, once again not really a huge issue just a slight pull. I then found teh cable and rewired everything and put the bezel back in. I then turned the computer back on after everything was rewired in the other spot and absolutely everything worked... except the touchscreen. Me and my friend reinstalled the Egalax touch screen stuff probably 10 times in different ways and nothing worked. It would always recognize that the touchscreen controller was there but every time I went to calibrate it and touch the screen where the arrows were at and nothing happened. I even wiped the drive and reinstalled the drivers and windows 7 and everything else worked but the touchscreen. It says everything is connected and should be working but the touchscreen is not... now to my question

    Is it possible that I could have done something in my transition of the computer to the new location? I literally just turned it off, moved the wires, and plugged it back in, so there should be no software or hardware problems. My only viable problem I can think of is that I must of either broke something or detached something from the motherboard in back. I took a flashlight and looked at the ribbons and they looked in-tacked and fine. I also pulled the VGI Hdmi cord out and checked it out and no real damage.

    Please I cant believe this is all happening and I would love for someone to let me know what would be my best next step in figuring out if I need to buy a new cord screen or something entirely different. Tomorrow I am going to take of the motherboard for a closer look but I really dont know what I will be looking for if something small is wrong. Thank you so much and I look forward to talking to someone!!