No announcement yet.

Red Light Only Lilliput EBy701 - Bricked or ribbon?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Red Light Only Lilliput EBy701 - Bricked or ribbon?

    I've seen many threads regarding the constant or flashing red light on various Lilliput touchscreens, all with varying results.

    Basically, is the board or LCD bricked? I've seen some reports that indicate a ribbon could be the culprit, but I've also read that the controller needs to be replaced. Is there a general consensus for this behavior, or maybe a diag code reference?

    The quick:

    Working 701 on AC while setting up laptop and dashboard. Tested in car and worked until pushing enclosure into dash. Ribbon came loose, then LCD became completely unresponsive despite reseating ribbon.

    The long:

    I bought a 701 off a friend of mine who abandoned his car PC project. The LCD worked fine and never got much use. I had had a complete laptop car PC setup that was stolen, and had everything in place but the touchscreen. Using the AC adapter, I configured the touchscreen for auto power on and my laptop's RR dashboard. Everything was working fine. After preparing the dash install, I tested power and video from my car out of the dash. Without having the laptop's video connected just yet, everything was fine other than no video source being detected. Once I had cable management out of the way, I slid the double din setup into the dash and tested again. It seemed that things progressively got worse. After testing again with it installed in the dash, I saw the blue lights flicker like normal, but no longer saw a video source in the upper right corner of the LCD. I verified connections, and noticed that the ribbon cable had come loose. Eventually, I got the ribbon cable seated again, but after testing it again, expecting it to work, I didn't even get the normal blue lights, only a solid red light on the power button. I brought everything back into the house and tested on AC and observed the same behavior.

    What are the odds that the ribbon is bad, or is this behavior indicative that I need to replace the unit altogether?