No announcement yet.

Pretty sure my brand-new EBY701 is defective

  • Filter
  • Time
  • Show
Clear All
new posts

  • Pretty sure my brand-new EBY701 is defective

    With great excitement, I unboxed my EBY701 and hooked it up to the hardware for my car PC - ASRock E350M1 board running Win 7 Ultimate. There's a red tint I can't seem to do anything about, and the touch functionality is nonexistent - I installed the drivers that came with it, along with the updated drivers straight from eGalax. Nothing. I hooked it up to my main desktop, an Asus M5A97 EVO running Win 7 Ultimate, same thing. I never even got the new hardware wizard, and after rebooting after installing the drivers, when I try the eGalaxTouch software, it can't find the monitor either. Is there something fundamental I'm missing, or am I right in thinking it's defective and just needs to be returned? My other concern, this one being as useless as it is, I'd rather not end up having to return the second one (at which point I'll take a refund), down $20 shipping it back twice and no monitor to show for it. That is to say, am I unusual in my experience? Lilliput's reputation seems decent, but the poorly translated website and documentation, along with the complete lack of support on their site have me a little leery. What say you, forum people? Exchange it and take the chance, or should I bag it and shell out a lot more for a Xenarc?

  • #2
    FWIW, I've got the display issue fixed, apparently. Just the same, though, the monitor does not show up as a touchscreen device no matter what I do. I tried the aforementioned eGalax drivers, along with the TouchWiz drivers, and nothing. All the references I've seen here refer to screens that have been disassembled, while mine has not. Unless someone has a magic suggestion, I guess I'll box this back up, send it back, and hope the replacement works correctly.


    • #3
      You say the monitor does not show up as a touchscreen device.

      Does this mean the touch works, but Win 7 does not see it in the Touch PC section of the Control Panel?

      Or is the touch screen completely dead?


      • #4
        The eGalax drivers are a generic driver and will be recognized as a mouse and NOT a touch device. I have had this same issue with a generic screen. I ended up loading Win7 onto my machine and it works fine but I would rather it was seen as a touch device too.

        You want to load the latest egalax drivers onto your computer to get this to work. I had a driver disk that was a few versions older and it did not work with my Win7 machine but once I downloaded the latest driver from egalax's website it worked fine as a mouse device. From what I have been able to find out so far you either need a different converter with driver that can be seen as a touch device or get a different screen because the egalax screens don't have "touch" drivers only "mouse" drivers.


        • #5

          That's what I was getting at. Win 7 won't see a resistive touch panel as a touch screen, or HID. Only as mouse.

          If you need a true touch screen device for your application, you will need to convert your 701 to a multi touch capacitive display.

          Otherwise, you will need to use the screen only as mouse emulation.


          • #6
            It doesn't even see it as a mouse, unfortunately. I installed the latest drivers from eGalax, and still no-go. The only thing that shows up under mice in Control Panel -> Hardware and Sound -> Mouse is the actual USB mouse I have plugged in. I also just noticed that in Device Manager, the system has no reaction to me unplugging the USB pigtail.

            Mouse emulation would be fine...if it worked. It doesn't show up at all in Device Manager, and doesn't respond to touch whatsoever.

            I think that tears it, then - I'll get it boxed back up and get an RMA for it. Thanks for the advice, though - it hadn't clicked that 'touchscreen' and 'multi-touch' are really quite different things.