No announcement yet.

cursor jumps around with lilliput software

  • Filter
  • Time
  • Show
Clear All
new posts

  • cursor jumps around with lilliput software

    my mouse (cursor) now has a mind of it's own. i will be using the laptop touchpad or the lilliput touchscreen and sometimes (at least 75%) the cursor jumps from under my finger to another part of the screen, and sometimes stays there, and sometimes jumps back to it's original position.

    weird. anyone know what's going on and how to fix it?

    also the usb port on my laptop is usb v.1.1. not sure if that has anything to do with it... but it does happen even when i'm not using the touchscreen, so i would almost rule out the usb version as a potential cause.

  • #2
    Is the screen in the original housing? Does the cursor jump to a corner or the edge? If this is the case, I have the same problem. Its because the case is pushing on the screen. I have the same problem, and its only due to a sloppy install into the DigitalWW fold out dash unit.

    If its not jumping to a corner, but instead jumping all over the place, are you using a serial GPS unit? If so, unplug it, and if the jumping stops, you have to go into your Device Manager and disable the Serial Mouse that Windows autodetected. Just disable it, don't uninstall it. Plug back in your GPS, and you should be in good shape.

    If these don't fix it, hit it really hard with a big hammer, and you won't have to worry about your cursor jumping around anymore....
    2000 Subaru OBS

    Dell P3 @ 900 Mhz
    7" Lilliput TS w/DigitalWW in-dash mount
    80GB External HD

    I am Zero Bitrate....


    • #3
      i'm getting the hammer ready...

      basically, yes - the i am using the original housing and no the touchscreen is not being pushed on. it doesn't jump to a corner or edge per se, but it just jumps somewhere else. i'm not using a serial mouse. no GPS installed. this happens when using the touchPAD on the laptop.

      thanks tho'


      • #4
        While searching for a fix for the jumping cursor problem I found the following fix from "ucidave" at:

        I had the problem of the GPS being mistaken for a mouse by Windows, and I tried the solutions presented in here:

        The problem is that the posted serial.reg on routis' website didn't work for me, and with Windows XP SP 2, as soon as I disconnected the GPS unit so the curser wouldn't be so crazy, the hardware list in the device manager to disable would also dissapear, making it impossible for me to disable it in the first place. (it's also near impossible to access the device manager when the curser is acting crazy) If I reconnected the GPS unit, windows would then fix the error (and the offending "fake hardware" in the form of a serial mouse wouldn't be there anymore), but disconnecting the gps unit and then reconnecting every time I boot is out of the question.

        The solution is to manually edit the registry by hand (for some reason, with SP2, the values did not change upon running the sermouse.reg file.

        first run regedit (start->run->regedit)

        browse to here: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sermouse

        change the value of "Start" to 4 (doesn't matter if it's hex or dec, but leave it how it was). It will probably be a value of 3

        this is the exact same values as in the reg file that routis supplies, but for some reason in my installation of windows XP sp2, it didn't work (it worked for when I was running sp1).

        Hope it helps.


        • #5
          Thanks mate. Appreciate the detailed answer. very useful