Announcement

Collapse
No announcement yet.

Lilliput TouchKit problem solved!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lilliput TouchKit problem solved!

    Greetings,
    I just got my Lilliput 7" touchscreen, and had a problem with the drivers and software that was shipped with it. After spending (wasting) a few hours here on the board, reading posts about how good or bad it is, and how much better the Xenarc screen is, I found a solution that may help a few people.

    The problem: Computer locks up during installation of the TouchKit software, usually after scanning the com ports. It only takes the work of a few minutes to see that a lot of people are having this problem. I hope this helps...

    The solution:
    1. After banging my head on the table trying to uninstall the bad drivers, I finally did a system restore. I tried deleting the INF files and registry entries, but the "Found new hardware" after reboot would not go away. I hate to resort to system restore, but that was my only option at that point.

    2. I downloaded the latest software from eGalax (the authors of the program) at http://www.egalax.com.tw Click on downloads and find your operating system. It seems to me that most people with this problem are using Windows XP.

    3. I installed the software without the hardware connected. After reboot, I connected the hardware, and let windows automatically configure the drivers.

    It all works fine now. I hope this will help some of you that have had a similar problem.

    Have a nice day!

  • #2
    Thanks! My TS has been out of commision for weeks, I had never thought of resorting to system restore... but it worked and now my TS is happily working! I hope this bumps for other people to see.
    My Carputer! (More Car Pics at the end)
    2 Kicker Comp 10"
    Epia M-9000, 256 MB DDR, 120 Gig HD
    Lilliput 7" VGA Touchscreen
    Check it out?!

    Comment


    • #3
      This should be added to the Lilliput FAQ. Add your directions to the FAQ when you get a chance. It'll be helpfull to a lot of people there.

      Comment


      • #4
        Worked a threat, never would have figgured that out on my own

        Comment


        • #5
          Hi, thanks for you tutorial.
          I would add teaching how to do the same think without restore the windows.

          Normally the windows, alwayas add the touch screen as a human interface.
          you can see on the device manager. But you can easylly discover plug the usb of the monitor touch and refresh the device manager, it will add one new device and when you unplug and refresh again this device will disapper.

          Now you know how to find the monitor touch screen on the device manager. Then you plug the touch again and on the pop up menu select "uninstall". Then close the device manager. Install the Egalax touch drive. Finally reboot that everthing should work. Worked to my, at least

          bye

          Comment

          Working...
          X