Announcement

Collapse
No announcement yet.

Lilliput Touchscreen Replacement

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lilliput Touchscreen Replacement

    What's up people. Like a lot of the people on the board I have a 7" Lilliput touchscreen that is now broken. Basically wherever I touch the screen the cursor always shows up on the right half of the screen, which leads me to say that touchscreen overlay is the problem. I PM'ed Armen like 2 weeks ago because I know he sells direct replacements for them and I have purchased replacement ribbon cables from him in the past but I have heard nothing. Does anyone know of an alternative? Also thoughts on what could be the problem are welcome! Thanks.

  • #2
    i could be that the touchscreen overlay is jammed between the tft and his housing. be sure this is not!!!
    maybe for test try to take your touchscreen out of the housing, but still let it be operational, and look if the problem is gone.

    gr qbics.

    Comment


    • #3
      i am currently working with a distributor to get touchscreen replacements...when i find out more ill let you know.

      Comment


      • #4
        I found that my touchscreen fit too tightly within the plastic housing tabs and trimmed the plastic a bit. You may try that. Also make sure that the backside of the front bezel is smooth and that nothing wedged itself in between there. I've seen this happen on 19" touchscreens that I used to service and it caused calibration problems.
        Fabricator

        Comment


        • #5
          I had this problem after I opened my case to fix a faulty vga cable! Basically I found that it has something to do with the ribbon cable that connects the touchscreen to the touchscreen controller. When i bend the cable it works, let it be straight it doesn't bend it not enough and I get erratic movements. Erratic being that the cursor would regularly jump the right hand side and be hidden there!

          Anyone know where to get a touchscreen ribbon cable?, not for the display - that works fine, rather for connecting the touchcontroller to the screen. Could only find the 40pin display cable on www.digitalww.com

          [edit]
          Argh just realised I have to replace the whole touchpanel to replace the little ribbon cable argh ! damn lilliputs! always breaking....
          [/edit]

          Thanks.
          Fox Mulder
          2004 Toyota MR2
          Modified Intel Xeon E5450 3Ghz Quad Core 2GB RAM 160GB SSD M4ATX Xenarc 700TSV TS Toslink Audio BU353 DiNovo Mini Car2PC ODBII Bluetooth HF 16x2 Character LCD

          Comment


          • #6
            Thanks for all the replies guys. When I took my screen apart I took the bezel off to make sure that nothing was pressing against the screen and I still had the same problem I personally am starting to get ****ed with Lilliput. This is my second screen and I am about to throw Zenarc some business.

            Comment


            • #7
              UPDATE : I just received my replacement touchpanel from digitalww but it does not have the same connector . I know that these are supposed to fit with no modification so I am thinking the problem is that I don't the Lilliput that Armen is selling...I bought in Nov 03'. Thoughts?

              Comment


              • #8
                Did your old panel have a tiny connector? I can send you a cable that will fit both the new panel and your Touch controller. Email me with your address.


                Thanks,
                Armen
                Originally posted by project94coupe
                UPDATE : I just received my replacement touchpanel from digitalww but it does not have the same connector . I know that these are supposed to fit with no modification so I am thinking the problem is that I don't the Lilliput that Armen is selling...I bought in Nov 03'. Thoughts?
                http://www.digitalww.com

                Comment


                • #9
                  I am having the same erratic touchscreen problem with my DWW-7VGT from digitalww (lilliput innards). It exhibits the problem sometimes and not others - is that most likely the dust/debris cause or the touch panel replacement?

                  I am sure I will end up going through both fixes, but I would like to know how others fare with this problemo.
                  HP e-PC 933pIII/40gb/256Mb, 12v->19v power, DWW-7VGT (Lilliput) wrapped in a Subaru LGT

                  Comment


                  • #10
                    It was the touch panel...replacement solved the issues. Hope this isn't a re-occurence every 4 months of use! I will try to be a little more "careful" I guess.
                    HP e-PC 933pIII/40gb/256Mb, 12v->19v power, DWW-7VGT (Lilliput) wrapped in a Subaru LGT

                    Comment

                    Working...
                    X