Announcement

Collapse
No announcement yet.

White Screen of death

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • White Screen of death

    I thought Bill Gate's blue screen of death was bad ... think again. The white screen of death hurts even more because that's 3 bills down the drain unless I can fix it by replacing the ribbon. Needless to say, it was a 7" lilliput w/ touch screen. I was so close to adding the final touch to my car, but like always, something bad happens. Not only do I get the white screen, but the colar that holds down the ribbon on the lcd side broke off. If anyone knows any cool fixes other than changing ribbon or lcd, let me know.

    http://www.calracin.com/carputer/sad.html

  • #2
    its the egg... its not getting enough voltage.. not joking neither.. check the voltage after the egg and you'll see about 6v.. seems the regulator splits into 2 tracks so 1 goes down and you still get half the power through...

    Watch it though cause you run it too long and the extra current to turn the screen on needed from 6v will melt the cable.

    Best option.. hock it to your pc's power supply and see if it then works.. if it does then you'll want a new regulated power supply.

    Comment


    • #3
      Originally posted by Skuzzle
      its the egg... its not getting enough voltage.. not joking neither.. check the voltage after the egg and you'll see about 6v.. seems the regulator splits into 2 tracks so 1 goes down and you still get half the power through...

      Watch it though cause you run it too long and the extra current to turn the screen on needed from 6v will melt the cable.

      Best option.. hock it to your pc's power supply and see if it then works.. if it does then you'll want a new regulated power supply.
      I was trying to revive the VGA and VIDEO screen using AC power with no luck. And the egg no longer connects to the cig lighter, it connects to the ACC.

      Comment


      • #4
        Originally posted by calvincbr
        Not only do I get the white screen, but the colar that holds down the ribbon on the lcd side broke off.

        I've got that problem also. I'm curious if there's a solution to this other than soldering a new connector.

        Comment


        • #5
          Originally posted by Ibiza96
          I've got that problem also. I'm curious if there's a solution to this other than soldering a new connector.
          i just sent mine back for warrentee :P
          my destinator map resource down permanently

          Comment


          • #6
            I'd suggest just trying a new ribbon cable if you haven't already... I'm also in the final stages of my project and was fiddling around a little too much with the ribbon cable, and ended up bending it, resulting in the white screen. Ordered a $6 cable from digitalww.com, arrived in 3 days, and fixed the problem right away.
            2004 WRX Carputer

            Comment


            • #7
              I broke off that damn latch too so now I have the WSOD! Someone suggested using duct tape and a glue gun to fix the problem- haven't tried it though....

              -Mike

              Comment


              • #8
                Lets hope that the new cable will fix the problem.

                Comment


                • #9
                  Just ordered a new cable. Maybe i'm gonna use hot glue to keep it in place instead of tape.

                  Comment


                  • #10
                    I too, have the WSOD. I tested continuity of the ribbon, and it was perfect. Do I still need to get another ribbon cable to rectify this problem?

                    Comment


                    • #11
                      That cable's connection is more like a PCI card than a power plug, meaning thatit might look like its plugged in right but its not.

                      Reseat the cable. I did that when I had the wsod with my lilly and it fixed it.
                      Debt as of 1/1/05: $34,354.48
                      Debt as of July 4, 2007: $0.00 explanation
                      I'M DEBT FREE!!
                      I'm now a reasonably successful gunblogger.

                      Comment


                      • #12
                        which one?

                        any one konw which type of ribbon cable you need to rectify the famous white scree problem?? is it the pins facing the oppisite direction or the same direction thanks
                        Lilitput 7" touch screen :-( , Epia -M 256ddr, Opus150w,

                        Comment


                        • #13
                          It's the same as the one in your Lilli. You have to look at it and get the right one.
                          7" Lilli TS, Soyo K7VME, Semperon 2200, 160GB Maxtor, 512mb PC3200, Deluo GPS, Panasonic Slim DVD/CD RW, Linksys WMP545G , Opus 150w, XMDirect, XP Pro, FP, IG [XXXXXXXXX-] 90%
                          ATVMS.com

                          Comment


                          • #14
                            Originally posted by sfay93
                            It's the same as the one in your Lilli. You have to look at it and get the right one.

                            HMMM. i now this sound bizare but i managed to loose it, long story but yes i managed to loose it, any help, its a 7" touch screen with the 10 pin din socket, thanks
                            Lilitput 7" touch screen :-( , Epia -M 256ddr, Opus150w,

                            Comment


                            • #15
                              You have the same side pins cable.

                              Armen

                              Originally posted by Mush
                              HMMM. i now this sound bizare but i managed to loose it, long story but yes i managed to loose it, any help, its a 7" touch screen with the 10 pin din socket, thanks
                              http://www.digitalww.com

                              Comment

                              Working...
                              X