No announcement yet.

Having Lilliput Disconnect Issues?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Having Lilliput Disconnect Issues?

    In following up with some new information on the thread from I've made a hair of progress.

    I first thought perhaps the USB Power management was causing issues, and I made triply-sure that all power management was disabled, down to the resource-level. I also double-checked all wiring, and made sure the wiring was correct.

    Here's one observation I'll note: The touchscreen stops working, and Windows no longer shows it listed as being plugged in, -but-, you never hear the "disconnect" sound played when it happens. The moment you physically disconnect the cable, you hear the sound, then if you reconnect it, you'll hear the "reconnect" sound.

    That leads me to believe it's a possible driver issue, but the drivers are current. My motherboard is USB 2.0.

    Here's one final set of observations. In the previous thread, I mentioned how the inverter occasionally shoots the cycle of A/C from 60hz to an odd number, like 68hz, for a split second--then it returns to normal. The voltage is a bit lower than in the house, but the power-supply in the computer handles 110 on up.

    I tacked a pair of wires onto the +5/GND lines on the touchscreen controller, where the USB lines run into. I decided to connect my DVM to the end of the wires, to monitor voltage on the USB to see if there was a correlation between the inverter and the motherboard.

    For the entirety of the testing, the voltage on the USB lines was a constant 4.96 volts, regardless of engine rev. This remained the same on both the Lilli controller, and seperate USB cables which I tested. However, at some point, for whatever reaosn, the voltage hopped up to 4.98. At that point the touchscreen stopped working. Again, no sound saying it was disconnected, even though as far as Windows was concerned, it was missing. A simple disconnect and reconnect yielded the nominal 4.96 again, and had the screen functioning again.

    I'm going to run 2 DVMs tomorrow to monitor voltage/herz on the inverter, as well as power on the supply-side of the computer. I have a feeling it's going to be one of 3 things:

    * Something on the hitachi-touch controller is whack and it can't take 2-hundreths of a difference in voltage

    * The spiking of herz from the inverter is causing something weird to the mobo

    * The power fluctuations from the inverter are causing some sort of driver problem

    Remembering the fact the screen never stops working while plugged directly into the house electricity, strengthens the fact it has to do with the electricity within the vehicle itself.

    Any feedback is much appreciated.

  • #2
    Final conclusions:

    After running tests in both the car and house today, the only thing I can come to a conclusion is the electricity put out by the invertor is causing the disconnect *somehow*

    The frequency of VAC in the house is 59.96-60.00 solid. The car's is 61.66-.99 with spikes up to 70hz. I believe that is the culprit somehow.

    Also, voltage seems to fluctuate more rapidly on the inverter for obvious reasons.

    How and why this affects the power going to the USB bus (and only the USB bus I might add, nothing else in the computer is affected) I'm not sure. While on the house's VAC, the USB +5 is a solid 4.96 no matter what. While in the car it's 4.96-.97, but the moment it hits 4.98 the TS stops responding unless I disconnect and reconnect the cable.

    So, my next thing is to find a new inverter and hope that fixes the issue, or find an alternative means to powering the TS. Perhaps another voltage regulator or something?


    • #3
      It could be that your inverter is not immune to transient voltages, and it feeds the disturbance straight into the motherboard.

      A regulator should fix this problem.

      Using my dc-dc board, I no longer have this problem. But if I take out the regulator from the dc-dc board, sometimes this will happen.
      New Lilliput EBY701 For Sale
      SiRF3 Bluetooth GPS


      • #4
        You're not the only one

        I'm glad I'm not the only one going nuts with this.

        My problem has been consistant for about 10 months now. Part of me just wants to rip the thing out and send it back to Armen, but somehow I don't think it's a hardware issue.

        Screen will work fine for a day or two, and then just stops working. If I'm on a long trip it will sometimes just start working by itself after 30min-1hr. Sometimes it's longer.

        There is the rare occasion that un-plugging it and plugging it back in will work. More often the PnP wizzard comes back up and I have to use the keyboard to re-install the driver. Even then it only works about half the time after that. *REALLY* annoying to say the least.

        I just put a USB 1.1 hub on today after reading another post on here and it worked like a champ for about 10 hours, and then it was back to it's old tricks again. Unplug/re-plug did not work.

        The fact that withen a single windows session it will work/not work/work again leads me to think that it's not a driver issue. If the driver crashed, then it would not resurect itself. btw, reboots never help.

        You may be onto something. I wonder if there is some sort of USB power regulator 'dongle' that could do the trick? I have a 90w Opus and don't see giving that up anytime soon.


        • #5
          Sounds like the drivers are crap. If it was a voltage problem then wouldnt other USB devices quit working? NO because their drivers are written better IMHO. I am still having touchscreen issues and I am at my wits end. My last resort is a full reformat tomorrow just to see what happens. I wish I had found this site well before I bought my lilliput or even started this whole carpc project in the first place but I am too far along to turn around now. When I tested the TS out just after opening the box it worked flawless. Mind you it was plugged into the motherboards 1.1 usb port. I then later tested it in the same port (now knowing it was port sensitive) with my 10 foot cable just to be sure it would still work after being extended. All was well. Tested it once again running on the cars power AND the inverter just to be sure. Again, no problems. As soon as I do my final install and plugged it into the 4-port USB 2.0 powered hub, no go wtf!! This drove me nuts for a week then I pulled up this site on a google search. After 3 days of searching and reading it is definatly a driver issue. Lilliput or whoever needs to address this problem. Its rediculous and makes me wish I never started dumping money into such a headache project. ANY USB device should be able to handle slight power and frequency spikes.

          I can relate this to my real-life job as an auto tech. Some of our modesl (Saturns) are super sensitive to misfires and will throw the check engine light on. Every car on the face of the planet misfires but you usualy don't even notice it. The software is just too sensitive to these "normal" occurances and sees a so called problem. This only causes greif for customers and they always want an explenation as to why they are getting charged for min. diagnostic fee. Same thing here. Its the damn software and drivers and needs to be handled. Who does their driver coding for them ATI?
          My carpc post: Relocated a/c + 6000 watts and 300hp *tons of pics*


          • #6
            so...going off of another forum members post I decided to do a full reformat and see what happens. The lilliput 8" touchscreen now works absolutly perfect no bs! I read somewhere that they are VERY picky as to what usb it is initialy installed on. I installed the TS on one of my usb 1.1 ports directly on the motherboard with a 10' extension to the front of the car. This way it is not on a shared hub and so far it has been good. No disconnects, works at boot up everytime, stays working over an extended period (tested it for atleast an hour twice) and it has not lost the TS when I connect other devices into my 4port 2.0 hub. So if you are having TS problems break out the cd burner, save files and reformat that sucker!
            My carpc post: Relocated a/c + 6000 watts and 300hp *tons of pics*


            • #7
              ok there has got to be a better solution than reformating everytime something as small as a usb device fails.
     Senior Tech Blogger (Want a product reviewed? Contact me.)
              Follow Me on Twitter or Facebook
              Live mp3Car Facebook Chat


              • #8
                I hear ya but it worked for me. After pulling my hair out for 2 weeks trying all sorts of things, reformatting actualy solved ALL of my problems. Its something in the coding for the drivers I am sure of it.
                My carpc post: Relocated a/c + 6000 watts and 300hp *tons of pics*


                • #9
                  I may try the reformat option, but it's a pain to retweak everything. Alot of people have said the sensitivity on the USB 2.0 is outrageous, and that it works flawlessly on their 1.1 (which was the case with mine).

                  Problem is, my new system is USB 2.0 only... If a new inverter (or regulator, if I can find one which handles 10 amps) doesn't fix the job, I'll try the format. It's a pain though, usually takes a good few hours to get all of my streamlinings into place.


                  • #10
                    Well, My lilliput 619 screen. has the same problem. It just stop reacting after a period of time (between 1/2 and 1 hour) and most of the time it stays off after hibernating.

                    But I think it's a powersupply problem. It didn't happen when I powered my carputer at an more stabalised netadapter.

                    I will make more test soon.

                    mayby its just the stability of the powersupply. Or it's the updated TS driver from that I installed.


                    I'v installed the latest version fromt he above URL but this isn't a sollution. the screen still hangs randomly after an period of time.
                    And it's an very rare problem. I can poweron my pc for more hours (24) without the screen on. when I enable the screen afther those hours.. its always responding.

                    But when I leave the screen on for the same amounth of hours. it offten stops responding.