No announcement yet.

Another 'unknown device' lilli touchscreen problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Another 'unknown device' lilli touchscreen problem

    I have searched, and there are posts complaining of this but noone has ever mentioned a fix for it, or if they sent it back, what was wrong.

    Hw: 7" Lilliput (10 pin version), M10K, XP Pro SP2 (clean install)

    Ive done this:
    1. Collected several versions of touchkit
    2. uninstalled ALL USB devices
    3. reboot with nothing connected to USB
    4. install Touchkit
    5. reboot
    6. plug in USB direct to mobo
    Thats where it comes up with the 'device not recognised' balloon and shows 'unknown device' in device manager.

    Tried manually showing it the drivers- get usual windows "this does not contain any information about your hardware" message. Burned a set to cd to see if that helped finding them. nope. Manually installed the infs from the disk, nada.

    All versions of touchkit s/w installs ok, but shows no devices (obviously).

    I have checked:
    1. all the pins are straight
    2. tested the lead with a multimeter- passed ok
    3. different drivers (4 versions from different sites, egalax, innotouch etc)
    4. different desktop XP pc, and a win98 pc (with win98 touchkit)- unknown still
    5. tried usb>ps2 adapter
    6. chipset inf and drivers are installed
    7. removed and reinstalled via usb drivers
    8. this m$ page;en-us;314464 ... it does show a dev id, nothing else looks out of order
    9. checked M10k bios, usb kb support is on, irq for usb is on

    And now I find out that my supplier, that I have a 1 year warranty with, claims that if I return it, because its over the 4 week grace period, it has to be sent back to hong kong and will take 8 weeks!! Not pleased.

    To cap it all, its got a damn lilliput qc sticker sealing the screen halves together so if i open it to see if its an easy fix needing a quick solder but find nothing, then bang goes any warranty.

    Sooo, what could be wrong?
    What else can I do? (if anything)
    What are the chances of me being able to fix it myself?
    Has anyone managed to *ahem* slip the sticker off somehow? (heat? hairdrier? but if it rips im in the doodoo.)

    I dont want to have to fork out for a new controller if I open it and find nothing wrong, but otoh, 8 weeks is a loooong time, itll be mid summer before i see it back....

    Thanks in advance for any ideas

  • #2
    does this put me up to the top again?


    • #3
      Originally posted by Mad Ad
      does this put me up to the top again?
      it did for a bit but people ignored it so ithoguht i would take the oportunity to post whore.


      • #4
        no surprise there then scouse m8y

        Probably 99% of the people havn't heard of this problem, and the 1% that have, dont know how to fix it... ahh well, perhaps i'll get lucky and maybe one person that fixed it themselves stumbles past this forum


        • #5
          Personally I'd look at the thread on here about touchscreen controllers, they are offering a controller free of charge which I think is the same as our touchscreen controllers.or at least compatible, worth a go, saves having to wait 8 weeks!


          • #6
            free? which thread- I cant seem to see it?


            • #7
              Just for the record, I couldnt fix it and ended up returning it to where it came from- fortunately we came to an arrangement over a motorised indash as a replacement so I never got to hear what was wrong with it.


              • #8
                it did that to me when i hooked it to a usb hub, i later hooked it to an extension and directly to the puter, and it works great .
                My Mazda 3s

                My Mazda 3s on Car Domain

                [||||||||||||||||||--] (90%)


                • #9
                  I had that problem... I installed the new drives and only plugged in the AC power cord directly to the Lilli. Then plugged in the VGA monitor and USB cable. I also Tightened the screw connector as tight as I could and that seemed to fix it. Mine just wasnt getting a good enough connection at the screw.

                  Hope that helps
                  2005 4Runner Sport V8
                  CarPC:Shuttle st62k, P4 2.40ghz, 512 ddr400, 160gb HD, Panasonic Slot Load cdrw/dvdrom, TerraTec Aureon 5.1 USB sound, 802.11G, Sprint PCS Vision Internet


                  • #10
                    Same Problem Here....

                    I have Lilli 7" in original housing no mods running of PC powersupply. Lately the touchscreen stops working and says unknown usb problem i have tried everything i know and cant isolate the failure, this is very frustrating and i am getting no response Phone, Email etc from Armen at digital WW, very poor service in deed.

                    Posible Problems:
                    Cable and connection - trested and inspected - OK
                    Dead LCd controller issue - unknown - ??
                    Computer not sending proper or dirty 5v voltage to contoler over usb - this seem plausable because the touch screen runs even with the screen off so all power comes from the MB USB power system.
                    -Windows Software driver problem - tested cant isolate updated usb abd touch drivers, seems to work better after rolback though- ??

                    any ideas folks, i am on my third install of windows due to coruption and i think this could be a USB driver issue, i have noticed if i kill the power to the pc during boot it makes it start in normal mode with the 30 second warning
                    screen and that fixes it for a while or brings it back after three or four reebots with not touchscreen at all.



                    • #11
                      I had this problem and was going to replace my controller then on saturday the device just started working again. I took the monitor out of my car to do the IR receiver mod and it just started working. Of course my ribbon cable crapped out the same day but hell you cant have it all right.
             Senior Tech Blogger (Want a product reviewed? Contact me.)
                      Follow Me on Twitter or Facebook
                      Live mp3Car Facebook Chat


                      • #12
                        I have had this problem a few times in the past. I currently am running lilliput gen 1 in the tm housing that Armen sells. I installed it myself and had some issues with it, sent to to Armen after roughly a years worth of use with no problems (got the problem then). Armen reinstalled it and fixed everything up. A few months down the road, i got the same problem again.

                        From what i've determined, it is mostly caused by wiring issues. Inside the indash housing, the wires from the lilly to the back would get caught on the latch everynow and then. Eventually it ate through the wires, video signal and touch. After repairing it, removing the latch and spring, I haven't had any problems in a few months now.
                        90 300zx twinturbo conversion
                        Epia C3, 512 ram, syntax mobo, 80 gig WD, Mediacar, GPS w/Routis, all behind drivers seat, 7in Lcd Lilliput VGA with Touch, wireless adapter for stumbling, Consult ODB1 adapter and data scanner.