Announcement

Collapse
No announcement yet.

HELP!! my lilliput may have broke!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP!! my lilliput may have broke!!!

    ok so while trying to mold my screen to my dash i took it out, logically...when putting it back in i ran into problems and now my screen wont turn on


    everything went in smoothly the first time but then the screen wouldnt turn on, but it showed that there was power (the red light)

    so i just figured that some primer got into the hole where the buttons go and i had to clear it out so the button could move better...i did that

    when putting everything back in i ran into probs
    first this:


    as u can see that little clamp thing broke off so i had no idea what to do at that point

    while trying to repair it i finally got it back in and held it down with electrical tape for the time being...
    as u can see in this next pic, that little black piece of paper had fallen off, and the same thing on the other side (where that piece touches)



    i didnt think anything of it at the time cuz i was rushing like an idiot and was just concerned about getting it to work

    so everything was in, and then i went to plug it in and i saw a spark in this region :



    after that happened, the screen wont light up anymore, the red light indication power but power off does not light up either, so im really screwed i think....

    the "?" in the last pic is pointing to what i believe to be the fuse...could i have just blown the fuse when the 2 pieces touched since those black papers werent there, or did something else happen...is it because the clamp on the one thing is not there, or something else? im really just lost and upset that i broke my damn screen i just got like a month ago, so any help is greatly appreciated

    thanks guys and gals

    ~tim

  • #2
    That's a bummer. Scouse or Jcdillin are probably your best bets for answering this.
    Only true postwhores remember everything they post

    REP CLUB IS DEAD
    LONG LIVE REP CLUB

    Comment


    • #3
      yeah you need to have that little peice of black paper in there and you probably blew the fuse which is that little white thing you have outlined

      either get a replacement from digitalww, or remove that fuse and replace it with a normal fuseholder

      you could just bridge the fuse, but next time something shorts out you will blow the controller
      肚子笑痛了
      S60 Install

      Comment


      • #4
        Pic is a little unclear, but I believe you are right about that being a fuse. Replace it and you're back in business.


        edit:Too slow!

        Comment


        • #5
          also make sure that the ribbon cable going to the LCD is in square and not uneven. Did you say that you got the little clip back in and held down, or are you just trying to hold the ribbon in with tape?
          肚子笑痛了
          S60 Install

          Comment


          • #6
            just tape...i dunno if any of u have ever taken that piece out to look at it but if u look VERY closely u can see a little nub for it to hold in place and thats what broke on the one side...so for now its held in with tape

            can i get that type of fuse at radioshack or something? would i have to solder it in place or anything?

            Comment


            • #7
              Originally posted by timdastis
              just tape...i dunno if any of u have ever taken that piece out to look at it but if u look VERY closely u can see a little nub for it to hold in place and thats what broke on the one side...so for now its held in with tape

              can i get that type of fuse at radioshack or something? would i have to solder it in place or anything?

              oh yeah, I have about 10 of em sitting on my desk that are busted, but if you only broke off one nub, then it will still go back in and lock. which is the best way, it really wont work very well with just tape

              you will not be able to get that type fuse at radioshack, but you could get a normal fuseholder and fuse and just solder that into its place
              肚子笑痛了
              S60 Install

              Comment


              • #8
                nah the tab needs to be jammed in. Normally one of the side hinge points breaks off but you will see the tab is thinner where it fits into the cable holder. as long as there is still one side tab IT WILL work. Just keep trying. put the ribbon cable in and then push the tab in at about 45 degrees. Then applying pressure into the connector click the the tab flat and it should hold. Be firm but not overly forceful. It may take a few attempts but keep trying. Tape will not work as the profile of the tab exerts pressure on the ribbon cable to keep it in good contact.

                If you mount an external fuse make sure you get a quick blow and I dount you will get one the same value (the pico fuse in the Xenarc is 3A) so get the closest one lower (i got a 2.5A quick blow for my Xenarc).

                That was the black paper there for? isolation?

                Comment


                • #9
                  Originally posted by Scouse Monkey

                  That was the black paper there for? isolation?

                  yea i believe so


                  How do u replace the fuse once i get it (gonna have to order from digitalww)

                  Comment


                  • #10
                    solding iron - and be very careful!

                    And make sure you earth yourself when working on it.

                    Comment


                    • #11
                      wow I hear a echo in here
                      肚子笑痛了
                      S60 Install

                      Comment


                      • #12
                        ok i got that damn little plastic thing back into place holding the ribbon down so i threw some electrical tape over the whole thing just so it never happens again lol

                        i also ordered a few fuses from digitalww...can some1 give me a somewhat "tutorial" of how to replace the fuse? i only have a small 15 watt iron and havent had too much experience with it...the only thing i did with it was my LED conversion on my climate control etc so i really dont know what to do any tips r appreciated

                        thanks for the responses thus far

                        Comment


                        • #13
                          it's very very easy, just heat each end of the fuse up very carefully, then very very gently lift up on one end of the fuse. it should start to come loose, just keep heating each end untill you get it free.

                          but dont lift to hard or you will lift the pads from the circuit board.

                          after you get the fuse free, just touch the pads briefly with the soldering iron to smooth them out.

                          then using tweezers just hold the new fuse in position, touch the end with the soldering iron and it should solder itself to the pad, then repeat with the other side

                          that should be it
                          肚子笑痛了
                          S60 Install

                          Comment


                          • #14
                            yea that sounds easy enough...thanks for the help ill keep u guys posted...if its not the fuse im gonna be real ****ed though

                            Comment

                            Working...
                            X