No announcement yet.

Powering LCD

  • Filter
  • Time
  • Show
Clear All
new posts

  • Powering LCD

    I have a mobile authority LCD. I am having trouble powering it up. If i hook it up in the car to battery power and accesory power it works fine. But at the moment i want to play with it inside and when i try to power it up from a atx psu the power light like flickers on each time i touch the wire but then immediately turns off. I am just wondering is there like a trick to powering it which i dont know? Thanks

  • #2
    I have a Pyle LCD and didn't have a problem at all powering it with a ATX PSU. I just cut off one of the molex connectors then attached a pair of female banana jacks the the 12v and ground. I then attached male banana jacks to the 12v and ground wires of the LCD. The whole point behind the banana jacks was so I could connect and disconnect the LCD from the case easily. Do you have a video signal going to the LCD at the time you connected the power? M.A.V.I.C. System
    Asus MB, PII 266, 192 MB Ram, 6.8" LCD, 6 Disk CD-ROM, 21 Gig HD, All-in-Wonder Video w/ TV Tuner, Irman, Windows ME, Winamp, Cobra III -- All in a custom acrylic case. MP3car Listings - Please add to it! :)


    • #3

      Which wire are you using?

      On the standard 4 pin power connector.
      The red is 5 volts.
      The orange/yellow is the 12 volts.
      SP13000|M2-ATX|512MB DDR400|2.5" 7200RPM S-ATA|Trans-7"|Slim SL DVD-CDRW|KEH 5.1 DSP|SB L!ve Ext|Gyration PowerMate|BT|WiFi|GPS|WinXP|VoomPC
      GPSing - Digital Speedo
      Relocating headunit and extending faceplate
      Button app to Alt-Tab between two programs


      • #4
        I used the yellow wire. I didn't have a video source going into it but i didn't the first time i connected it to the car either so dont think that is the prob. I have a feeling it is something about the power to the accessory wire, because i just put both of these on the 12v wire together and grounded the rest (when connecting to atx psu), where as in the car i had acc wire to the acc and power to power. Hmmm i'm not overly phased because it still works, was just curious if was doing something completly wrong.


        • #5
          you need to have the ATX supply plugged into a Mobo, or use an AT.
          Clarion 200watt head unit w/ Aux in.
          Kicker 800watt 4 channel amp
          In a 96 Grand Prix SE.


          • #6
            on my lcd's, you need to have a video signal present in order for the screen to fire up
            99.9% complete.



            • #7
              i have the mobile authority lcd too and im having the same problem... i have tried EVERYTHING!!! how do i get it to turn on after theres a video signal anyway? capacitors? this sucks!