Announcement

Collapse
No announcement yet.

Xenarc officialy the tuffest screen out there

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xenarc officialy the tuffest screen out there

    Well, Xenarc truly deserves an award for this one.
    I was sure i fried my screen when smoke started coming out of it. Anyone would think that.
    To be clear on what happened, i recently installed a reverse camera and for the power i decided to put a RCA connector (for easy disconnect/connect). I soldered it on and bent the tab to hold the wire. Now i never noticed that when i bent the tab, it actualy broke thru the jacket and created a short, sending a nice deadly 12v to my screen's aux input. I was ****ed !

    I didn't dare to try again in fear of making things worst but i took the courage and tried once more, this time soldering the wire solid with shrink tubing. I turn the thing on and blamo IT STILL WORKS !!!!!

    After sending a nasty 12v to my aux input, it still works.

    Thank you so much Xenarc for making such high quality product

  • #2
    Help! cant connect the reverese camera

    Originally posted by Nicorolla View Post
    Well, Xenarc truly deserves an award for this one.
    I was sure i fried my screen when smoke started coming out of it. Anyone would think that.
    To be clear on what happened, i recently installed a reverse camera and for the power i decided to put a RCA connector (for easy disconnect/connect). I soldered it on and bent the tab to hold the wire. Now i never noticed that when i bent the tab, it actualy broke thru the jacket and created a short, sending a nice deadly 12v to my screen's aux input. I was ****ed !

    I didn't dare to try again in fear of making things worst but i took the courage and tried once more, this time soldering the wire solid with shrink tubing. I turn the thing on and blamo IT STILL WORKS !!!!!

    After sending a nasty 12v to my aux input, it still works.

    Thank you so much Xenarc for making such high quality product
    I didnt understand why it happend and how to solve this but the same white smoke came out of my monitor something is obviously burnt.

    anybody?

    Comment


    • #3
      AUX input probably has capacitor connected in line. Probably you just burned your capacitor

      But Xernac is the best anyway !
      -------------------------------------------------
      BMW X5 Carputer Project
      Finished: 85%
      http://www.mp3car.com/vbulletin/show...lots-pics.html

      Comment


      • #4
        Originally posted by vinzer View Post
        AUX input probably has capacitor connected in line. Probably you just burned your capacitor

        But Xernac is the best anyway !
        +1

        Thanatos.
        RexBruMet Skin for FrodoPlayer

        Nissan Aux-in MOD


        Originally posted by bgoodman
        We're an international forum, post in whatever langauge you like.

        Comment


        • #5
          Interestesg....A similar thing happend to me. I reversed the power connection to my backup camera and noticed smoke coming out the back of my Xenarc. I assumed that the aux inputs were fried, I'll hook it up again (correctly this time and see if the aux input still works.
          My Celica Carputer Install

          Comment

          Working...
          X