Announcement

Collapse
No announcement yet.

Lilliput screen wont turn on(buttons but no screen) how can i trouble shoot?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lilliput screen wont turn on(buttons but no screen) how can i trouble shoot?

    lilliput touch screen will not turn on i tested my power setup before putting it in the car and everything is fine then its in the car the mac boots up but no screen. the power buttons are lit but the screen shows no response.

    is it possible that there was a voltage spike that could have killed the screen and not the whole unit. the power volume and input buttons all illuminate but there is no power to the screen. i took it out and plugged it into a wall outlet with the AC adapter and still nothing. usually the menu will at least come up or the input titles with u flip through them but this time nothing..

    is it possible for just the screen to go but the buttons and unit to still function? if so is there anyway to fix this or am i buying a new screen and a more secure 12v powering setup?

    i would greatly appreciate any advise i could get. this as i guess u all know isnt the most popular trick to do to your car and there arent many outlets that i can turn to. i value the experience that many of you have


    ps i tried searching but coulnt find any clear answers
    1993 Rx7 04' Scion xB - Toaster
    93' RX-7 - Show Boat
    My Car Domain

  • #2
    If the power button llights, but no display, could be several things.
    I loose lcd panel cable, or the inverter is not powering, or any number of things could result in your Lilli's problems. If you are comfortable with opening the unit, have a look and verify that all connectors are seated properly. Do this without power connected.
    I doubt you experienced a voltage spike, as the led is on. If you killed it, you would not even have that.

    Comment


    • #3
      how r u hooking up ur screen? thru opus or inverter? it's either the ribbon cable or the power isn't enough to power up everything///
      Progress Bar: [//////////]100%

      Have M10000, 40gb 2.5"hdd, i guidance, wireless,slim slot drive, delorme gps, roadrunner, liliput touchscreen, opus150w ...
      all fabrication done...

      Comment


      • #4
        the small fuse on the board might be blown. only way to find out is to open it.
        Installed
        Asus A7N8X-VM - AMD Mobile Athlon 2400
        512 Ram - 60GB HD - Opus 150w
        Lilliput 7" - Rikaline 6010
        [00000000000001100010-] 98% Completed

        Check Out My Install!!!

        Comment


        • #5
          The carpc might be misconfigured to show a screen solution that the screen dosn't support. I've tried that one myself.

          Comment

          Working...
          X