Announcement

Collapse
No announcement yet.

help with xenarc....nothing on screen

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • help with xenarc....nothing on screen

    I have nothing on my 700tsv screen...no monitor cable is plugged in...after i power it on the green light starts flashing.....I'm guessing that the inverter is fried...is that a correct assumption???

  • #2
    possibly. I'll take it off your hands for $100 shipped if you like

    Comment


    • #3
      i will keep that in mind....

      Comment


      • #4
        need help!!! bump....

        Comment


        • #5
          Dude, I think he was just yanking your chain...

          Let me get this straight, you don't have anything plugged into the Xenarc and you get a green flashing light. That's by design. If it doesn't detect a signal, it will go into standby mode and just flash that green light. Plug a source in and select it and the screen will display whatever you fed it.

          Comment


          • #6
            259 post but still a noob!
            i got dat ***** sittin on 22s! SUPERMAN EDITION!

            Comment


            • #7
              The Xenarc does flash the green LED when it is receiving no signal. But when you press the buttons (i.e. the vol up/down) it should turn on and display something on the top left corner of the screen.
              PowerVoice v1 | NaviVoice Source
              GammaControl v2.4
              SKINbedder v3

              1995 Lexus SC300

              Comment


              • #8
                i know...thats the problem.....i'm getting nothing on the screen even with a source and if i press the menu button or volume button i still get nothing...

                Comment


                • #9
                  Originally posted by joelw23
                  i know...thats the problem.....i'm getting nothing on the screen even with a source and if i press the menu button or volume button i still get nothing...
                  Ok. Do the CCFLs come on when you press the power button? If they don't, then can you see something very faint on the screen when you look at it next to a light?
                  PowerVoice v1 | NaviVoice Source
                  GammaControl v2.4
                  SKINbedder v3

                  1995 Lexus SC300

                  Comment


                  • #10
                    the ccfl's don't come on......i can't see anything on the screen either...but that might just be me...

                    Comment


                    • #11
                      Originally posted by joelw23
                      the ccfl's don't come on......i can't see anything on the screen either...but that might just be me...
                      But do you see anything on the screen when you touch the buttons? Like put it next to a light at an angle and check.
                      PowerVoice v1 | NaviVoice Source
                      GammaControl v2.4
                      SKINbedder v3

                      1995 Lexus SC300

                      Comment


                      • #12
                        no i can't

                        Comment


                        • #13
                          Originally posted by joelw23
                          no i can't
                          Hmmm.... maybe you blew a fuse?

                          If you haven't opened up the screen, contact Xenarc Warranty and have them take care of it.
                          PowerVoice v1 | NaviVoice Source
                          GammaControl v2.4
                          SKINbedder v3

                          1995 Lexus SC300

                          Comment


                          • #14
                            it's out of the case....i know the lcd isn't bad because it worked on my 700Y controller board...
                            so i'm guessing now that it's the controller board..

                            Comment


                            • #15
                              it's the ole inverter

                              find a source for one or ship it to me so I can work on it

                              Comment

                              Working...
                              X