No announcement yet.

800x480 on the SP13000 with Powerstrip

  • Filter
  • Time
  • Show
Clear All
new posts

  • 800x480 on the SP13000 with Powerstrip

    Trust me, I've searched and read through all the threads on the subject.

    We need to figure out a definitave answer on this subject. I have the SP13000 and the latest bios and I have the 800x480 option in "List all Modes," but I have a Gain 700TSV and using that option the screen displays some weird 640x480, which seems to be the case with everyone else with this setup.

    BUT, if I use Powerstrip, I can get true 800x480 by using the timings on the Xenarc Website here. The problem is, things don't stay this nice upon reboot. With Powerstrip set to start with Windows and restore the configuration profile for my working 800x480, the 700TSV goes into the weird 6400x480 mode and not the proper 800x480 mode (even though Windows thinks it is in 800x480 mode). If I then open Powerstip Configuration, the mode changes properly to the correct 800x480.

    So my conclusion is that this is possible. There must be a way to get this working. Does anyone else have any ideas?! Perhaps we could write a script that runs and somehow opens the Powerstrip display settings and then closes it, which makes 800x480 work every time (that is, once the actual display timings dialog is opened, the screen always reverts to displaying a true 800x480 every time). Is there any other software other than Powerstrip that allows setting resolution timings? I'd love to hear everyone's status on this issue and whether anyone has found a solution. It must be possible!

  • #2
    Well I'm a step closer now. I've messed around with Powerstrip so much I can barely see straight but here is a hack that at least works (although it isn't the most elegant solution).

    I found that Powerstrip can be run as a service before users login (that is, the service runs before users login or autologin). So I set Powerstrip to load as a service. During the login screen, the screen still does not display a proper 800x840. It just goes into a funky 640x480 with the screen off-center. Windows (at this point) thinks it is 800x480, but the screen says it is 640x480. But Powerstrip is set to "Auto-Load with Windows" and "Restore Settings on Startup." After login, windows thinks for a bit and then loads Powerstrip. The screen refreshes into a couple of different resolutions and goes blank for a sec, then it finally refreshes into a proper 800x480. So doing it this way ultimately works!

    My problem is that I'd like it to get to a proper 800x480 faster. Here is what doesn't make sense: whenever I go into Display Profiles and add the Advanced Timing Options listed on teh Xenarc website, my monitor quickly refreshes into the proper 800x840 - it works. BUT, when I restart (not using the services hack described above), the resolution is listed as 800x480, but the monitor displays teh funky 640x480 resolution. Powerstrip loads fine and Preferences are set to Auto-load with Windows and Restore the Display Settings on Startup, but the resolution is not restored.

    Now, if, after a restart, I then open up Powerstrips's Display Profiles Configuration, the screen immediatly refreshes and starts to show the proper 800x480. This occurs simply by opening the Display Profiles Configuration dialog, nothing more. This tells me that Powerstrip is not properly loading my custom timings when Windows loads, but it does load the proper timings whenever I open the Display Profiles dialog.

    There must be a reason for this. Why won't Powerstrip load my Custom Advanced timings when it loads up normally? Why woudl it not work when Windows loads and then work immediatly when I load the Custom Display Profiles dialog? The search continues...


    • #3
      I also have a SP13000 and a 700TSV. I'm on the newest bios and drivers. I think I might have a similar problem. I can get windows to select 800x480 and it seams to actually display that resolution on the screen. The screen says its running at 640x480, but I'm pretty sure its actually doing 800x480. And the screen is about .25-.5in off to the left. So every time I turn the screen on and off its off center.

      When you get yours set properly with Powerstrip, does the screen actually report running in 800x480? Or does it still says its in 640x480?


      • #4
        Yes, and I've determined that Powerstrip is required. When mine is off-center like that, the screen reports 640x480 and I'm almost certain that it is actually displaying 640x480. With Powerstrip it reports 800x480 and the screen is perfectly centered. Also, the resolution is much more crisp and everything looks great. When it is actually 800x480 you'll know it.

        I think the best solution is this (my latest solution): boot windows and run powerstrip. Get 800x480 working in Powerstrip - like I said, you know it when it works. It may take some playing with the settings, but mine worked with the ones on the Xenarc website. Once I have powerstrip up and running, just use hibernation instead of shutting down. This way, Powerstrip setrtings are saved and load quickly when Windows boots (resuming from hibernation). This seems to be the quickest solution into a perfectly working 800x480.


        • #5
          Could you specify what driver version and BIOS you used to get this result?

          I have a SP13000 with BIOS 1.17 and VGA driver

          In Powerstrip 3.64 Build 540 I can't select 800x480

          Also in windows display properties, when I check the available resolutions, 800x480 isn't there.

          Please help me out here.


          • #6
            Well, Powerstrip version is 3.64 but not the international version - I use the English version, not the International version (which I tried, but strangely couldn't get it to work).

            The Bios version is 1.07 I believe. Don't knwo where you can get 1.17 for the Epia SP-13000 - the driver download is here.

            I'm not sure about the video driver version number, but it was the latest as of a month or two ago when I updated it.

            The setting is not in the windows display properties. You must use powerstrip and go to the Advanced Timing Options and use the values found here.

            Hope this helps. If you have any other questions or you need me to figure out my video driver version, let me know and I'll try to find it!


            • #7
              Thanks, I think my problem might be Powerstrip.

              The advanced timing button is greyed out, so I can't get to that screen. Do you have any idea what could cause this?

              PS my BIOS is also 1.07. What settings do you use in the bios (i use CRT and LCD panel @ 1024x768 as this seems to give me most options in Powerstrip)


              • #8
                Yeah you could post to the powerstip forums to see how to get the advanced timing options open. That is the only way you'll get it to work, because you have to use the timings on the xenarc website and that is the only way to set those timings in Windows that I know of.

                Going back and looking, I think my powestrip version is 3.36, not 3.64 as I previously indicated.

                I seem to remember that the bios setting didn't matter, but just in case, I set mine to LCD 800x600

                You definitely need to get PS to work. Try using 3.63 and see if you get advanced timing options. I might have an installer for 3.63 if you need it, but I'll have to check to see if I still have it.


                • #9

                  Do you still have the installer for the earlier version of Powerstrip?

                  I've been following your thready here and can't resolve my display issues.
                  I'm having the same problems with my SP13000. I have the latest video drivers, Latest bios, Latest Powerstrip and..... yup.... greyed out 'Custom Resolutions' button.

                  It must be possible if you got it to work. What version of the video driver do you have? There must be something we are missing...

                  any help would be greatly appreciated.

                  *edit* nevermind... I flashed the bios and all is good now... *banging head on desk*


                  • #10
                    Originally posted by pneuwanda
                    *edit* nevermind... I flashed the bios and all is good now... *banging head on desk*
                    I still didn't get it to work. Could you tell me what bios version, video driver version and procedure you used please?

                    By the way this is the reply I got from Epia regarding my question about 800x480:

                    None of our BIOS supports 800x480 display mode as this is not a common wide screen resolution. We do have 848x480 (or something close to this resolution) included in the new BIOS...


                    • #11
                      I d/led the latest bios and Video per Via's website yesterday. Installed the video driver, rebooted to bootable CD Rom, flashed the bios, restarted, checked display properties in windows.. and Voila! 800x480 appeared! Didn't even need powerstrip.

                      It was late last night, so I could be dreaming, I'll check again this evening to make sure I wasn't imagining it.

                      *edit* I just checked again to make sure I wasn't dreaming... yup its running 800x480. Although my monitor says that its running at 848x480 for some reason. (I have the Super brand, generic xenarc monitor)


                      • #12
                        and did you check? Seems to me that's impossible. If not please let me know the version numbers of bios and videodriver.


                        • #13
                          Originally posted by hapklaar View Post
                          and did you check? Seems to me that's impossible. If not please let me know the version numbers of bios and videodriver.
                          Yes i need those version nos. too please.

                          Final Touches

                          Car: 2002 Mitsubishi Magna EI
                          CarPC: SP13000, M2-ATX, 512 MB RAM, 120 GB 2.5" HD, X-Fi Sound Card, Xenarc 700TSV, Garmin 18 USB.
                          Audio: 2X15" Rockford Punch Z, 1 Rockford Punch 2-ch Amp, 1 Soundstream Lil Wonder II 4-ch Amp


                          • #14
                            powerstrip 3.36?

                            Hi theminor,

                            I am having the same problem as you do, sp13000 with latest bios (1.07) xenerac 700ts, but I am using powerstrip 3.7 (the latest version) and I just couldn't get the "custom setting" button to work, it always grayed out. If you have a older version of powerstrip, would you mind send me a copy and let me try? I do tried the old 2.78 version, and that's plain doesn't work at all. I've set the display setting in the bios to LCD 800x600, and 640x480, still no go... I wish we are all as lucky as you are, at least you can get it working somehow.

                            Thanks in advance. oh, btw, my email address is: [email protected] Thanks again!!


                            • #15
                              i am wondering.. can you add a pci video card to solve all these issues and if so which one will work, all that is needed is to display 800x480....
                              btw is still very new to this game, my ambilicole cord is still attached to the FAQ section, but i cant find any post on the sp13000 and video cards