Announcement

Collapse
No announcement yet.

Touchscreen problem...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Touchscreen problem...

    Hi all,

    I've got a LinITX Plus 7" Widescreen TFT in my dash. Has been working fine for the last week, and today the touchscreen stopped working. Whenever I touched the screen, it shot off to a corner (not always the same corner).

    Unfortunately I had to hack it apart to get it in the car so I have no warranty.

    Did some testing, and ended up replacing the touchscreen PCB between the USB and resistive panel with a spare. Worked great, for about 5 minutes. Then it stopped working again

    Before throwing the entire thing against the wall several times then placing in the bin, does anyone have any suggestions? Drivers install fine, I can run the calibration, it recognises I'm touching the screen, it just always shoots to the top right or bottom left

    Other USB devices work fine, this screen has the problem in all USB ports on multiple PCs.

    I'm tempted to buy a motorised DIN unit instead so I can keep the warranty intact. Only problem is that I'll then have spent 500 on TFT screens for one car in the space of a couple of weeks

    Any suggestions gratefully recieved, having to use a mouse isn't a very good stopgap

    Regards,

    Scott
    SB

    "The gene pool could use a little chlorine..."

  • #2
    might be a reach... and I might be missing something or you may have already checked, but is the touchscreen film over the monitor getting pinched or pushed in those areas?

    Comment


    • #3
      do you have another input device like a mouse attached to the pc?
      Jan Bennett
      FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

      Please post on the forums! Chances are, someone else has or will have the same questions as you!

      Comment


      • #4
        ah right. gps receivers sometimes cause the cursor to jump around...

        Comment


        • #5
          actually I've never experienced that but I guess that it could happen?

          I just know that if you install the TS drivers and you have a mouse plugged in, the computer is essentially seeing two input devices and it goes haywire...sometimes.
          Jan Bennett
          FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

          Please post on the forums! Chances are, someone else has or will have the same questions as you!

          Comment


          • #6
            well the problem with gps receivers is that WindowZ sometimes sees them as being serial mice, because of the way the drivers convert the signal and create a virtual serial port etc. Has to do with the plug-n-pray side of things. Causes the cursor to jumping ALL over the screen, usually off the screen. There is a fix for that though which I host on my site now HERE. Found it here on the site somewhere... :-p

            Comment


            • #7
              It still does it with the GPS unplugged. No mouse on the system normally, there is temporarily at the moment.

              Still does it with the screen completely removed from the casing too

              With the latest drivers, the behavior has changed to nothing happening on the PC at all.

              Looks like the actual overlay itself is acting up - the little LED on the controller board lights up quite happily on touch.

              Where can you buy a replacement overlay from?
              SB

              "The gene pool could use a little chlorine..."

              Comment


              • #8
                Originally posted by SBDJ

                Where can you buy a replacement overlay from?
                hmm ok. well Digital World Wide Has'm

                Comment


                • #9
                  I've just pulled apart my old screen and hooked that up to the current USB controller and it works fine. Unfortunately it's well and truley glued to the screen so I can't rob it.

                  Definately a cream-crackered panel though

                  Thanks for your help guys
                  SB

                  "The gene pool could use a little chlorine..."

                  Comment


                  • #10
                    glad you figured it out and good luck with a replacement... later...

                    Comment

                    Working...
                    X