Announcement

Collapse
No announcement yet.

Lilliput 619 Blank Sreen?? HELP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lilliput 619 Blank Sreen?? HELP

    I have had a Lilliput 7" 619 installed and working great for about 2 years now. Never opened the case. So everything is working great when yesterday, I turn on the car and my screen is blank (all the Leds are on), while the music is rolling. I turn it off/on nothing, still blank . I tried to change the input, still blank not even the green letters . Menu button same thing. It is just dark. I am guessing that it maybe the lamp, but I hoping that it could be a fuse somewhere on the system? What do you guys think? HELPP

  • #2
    Anybody?

    Comment


    • #3
      You might try waiting more than an hour for someone who may have an idea to actually read your thread and post a helpful response....
      Have you looked in the FAQ yet?
      How about the Wiki?



      Under normal circumstances, a signature would go here.

      Comment


      • #4
        Sorry I am just so upside down right now. I will wait.

        Comment


        • #5
          Anyone have any ideas, or at least incling of an idea?

          Comment


          • #6
            Ok I took the plung and opend it up. I don't see anything burned. Also When I opend it up, I connect the power and turned it on. I couldn't see any light inside (aside from blue LED from the button section)
            Would that mean that the inverter is dead? I doesn't look like it has any burns (Check the picture)
            If the one of CCFL was dead it would still have some light from it and the other ones rigth? How do I get to them

            Also I tried to see if putting a battery lamp close to the screen hoping I will see anything when the screen is on, but NADA

            Here are the pictures

            what should I do next?
            What vould be the best way to check if the inverter is fine?
            I have a voltmeter, butI am not sure what current ot check for.

            Please Help
            Attached Files

            Comment


            • #7
              Ok after thinkering with the screen today, I figured out the the inverter has blown (I hope the backlight is still good). I was trying to see waht kind of power the inverter puts out, but I got 0V so after carfully inspecting it, I found some burn marks. (see picture). Now the question for everyone. Where do I get this part, I am not even sure what it is? The only mark on it is 7370 9473J Please HELP
              Attached Files

              Comment


              • #8
                OK so I figured that it is the step up transformer. ny ideas where I could find the specs

                Comment


                • #9
                  Same Prob.

                  Hey i blew my inverter too. did you ever find out what the specs on it were to order a new one?

                  Comment


                  • #10
                    my screen is just blank white now. i just mounted it in my bezel and now this. i have the eby701. anything new?

                    Comment


                    • #11
                      sent it back to lilliput and havent heard anything back

                      Comment


                      • #12
                        i cant send mine back. i got it off ebay.

                        Comment

                        Working...
                        X