Announcement

Collapse
No announcement yet.

Litton Mobile VU

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Litton Mobile VU

    Greetings,

    I have just this morning learned of the Litton Mobile VU but can find little info on it. I would like some specs on it if it is still available. Do you know of a source other than eBay?

    The reason for my interest is that we need to put some touch screens in trucks. They could be in-dash or yoke mount, 7 or 10.4". A couple requirements are viewability ( is that a word?) in sunlight and a USB interface for the touch screen. We were looking at a Lilliput but saw that it has some problems when cold, etc.

    Any suggestions would be appreciated as this is new territory for me.

    Thanx,

    john

  • #2
    Found it.-

    Found it here:
    http://www.l-3com.com/rcc/products/mobilevu/index.html

    Comment


    • #3
      I have an older 10" Litton Mobile Vu in my truck.
      It is very bright and is readable in any light. Colors seems fine and the resolution is fine.

      But... It's very heavy and bulky. Also mine is serial interface for the touchscreen.
      You can buy them for around $100 from time to time.
      ...Paul

      Comment


      • #4
        Anyone know of drivers that work?

        I bought one of those screens and they are nice but good luck getting drivers to work. I've tried the UPDD ones linked on this forum and the ones from 3M and neither worked. Anyone know where to get the correct drivers?

        Comment


        • #5
          greaserysub - your first post was moderated. It's a feature that we have enabled here on this forum to help prevent spam postings. As a new member, your first 5 posts are subject to moderation. The next time this happens, just be patient. A moderator will be by shortly to approve your post.
          Jan Bennett
          FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

          Please post on the forums! Chances are, someone else has or will have the same questions as you!

          Comment


          • #6
            Originally posted by greaseysub View Post
            I bought one of those screens and they are nice but good luck getting drivers to work. I've tried the UPDD ones linked on this forum and the ones from 3M and neither worked. Anyone know where to get the correct drivers?
            I have the CD I used to sucessfully setup mine. I can send you the files.
            ...Paul

            Comment


            • #7
              Paul,

              That would totally

              Can you send them via email to hankallan(at)yahoo(dot)com?

              or I'd even send you a disc or something...anything to get this puppy working!

              Thanks
              Hank

              Comment


              • #8
                Originally posted by greaseysub View Post
                Paul,

                That would totally

                Can you send them via email to hankallan(at)yahoo(dot)com?

                or I'd even send you a disc or something...anything to get this puppy working!

                Thanks
                Hank
                Files sent via e-mail
                ...Paul

                Comment


                • #9
                  Thanks Paul for the drivers. As far as I can tell it's the same UPDD software I tried previously. So maybe the configuration is the key thing.

                  What controller did you choose that worked - was it the Carroll Touch Guide Wave? Did you change the hardware settings or did it simply Auto Detect?

                  Comment


                  • #10
                    Originally posted by greaseysub View Post
                    Thanks Paul for the drivers. As far as I can tell it's the same UPDD software I tried previously. So maybe the configuration is the key thing.

                    What controller did you choose that worked - was it the Carroll Touch Guide Wave? Did you change the hardware settings or did it simply Auto Detect?
                    I've sent you an email with the setup instructions i used.
                    It did take a little playing around. I believe it auto detected the hardware but I think I then had to play with some of the configuration settings. (My PC is down at the moment so I cant check it.)
                    Note I am running windows 2000.
                    ...Paul

                    Comment


                    • #11
                      This thing might be toast

                      Ok I got the setup hints Paul. No joy yet. I even tried another pc running Windows 2k just in case. Changing the com port settings didnt help. But it's possible I just havent found the winning combination like you did. When your pc is running again take a screenshot of the hardware tab that shows the configuration, if you dont mind.

                      thanks again
                      Hank

                      Comment


                      • #12
                        Originally posted by greaseysub View Post
                        Ok I got the setup hints Paul. No joy yet. I even tried another pc running Windows 2k just in case. Changing the com port settings didnt help. But it's possible I just havent found the winning combination like you did. When your pc is running again take a screenshot of the hardware tab that shows the configuration, if you dont mind.

                        thanks again
                        Hank
                        With any luck I will be setting it up on another PC this weekend. I'll let you know how it goes and record the solution.

                        Comment


                        • #13
                          Originally posted by greaseysub View Post
                          Ok I got the setup hints Paul. No joy yet. I even tried another pc running Windows 2k just in case. Changing the com port settings didnt help. But it's possible I just havent found the winning combination like you did. When your pc is running again take a screenshot of the hardware tab that shows the configuration, if you dont mind.

                          thanks again
                          Hank
                          I reinstalled the touchscreen today. Initially I had a problem, eventually traced to the Com driver. I simply deleted the driver, restarted the PC and the reinstalled the touchscreen app. It worked perfectly without any additional setup. This was on XP.

                          If this doesnt work you could try the SW600071 driver from this site.
                          http://www.touchscreen.com.hk/download.htm

                          Good luck

                          Comment


                          • #14
                            Originally posted by pshadwick View Post
                            I reinstalled the touchscreen today. Initially I had a problem, eventually traced to the Com driver. I simply deleted the driver, restarted the PC and the reinstalled the touchscreen app. It worked perfectly without any additional setup. This was on XP.

                            If this doesnt work you could try the SW600071 driver from this site.
                            http://www.touchscreen.com.hk/download.htm

                            Good luck
                            ==========
                            Hmmmm...I wonder why it's nearly plug and play for your setup. I've tried both com ports with many different settings. Are you using 9600 8-N-1 or something non-typical? Oh and your RS232 cable is straight-thru normal serial not crossover right? I tried both just in case.

                            Comment


                            • #15
                              Not a null modem RS232 cable.
                              It seems all SFP serial driver of UPDD can work, no matter you choose Guide Wave or whatever.
                              However, my capacitive touch seems not sensitive and inaccurate compared to my Lilliput. Is this normal?

                              Comment

                              Working...
                              X