Announcement

Collapse
No announcement yet.

Xenarc 700IDT - no more VGA display?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xenarc 700IDT - no more VGA display?

    Hi guys

    I've been using this LCD touchscreen for about 2 months now for my CarPC. All of a sudden, when I booted my carPC up, the monitor no longer displayed a VGA signal. However, if I touch the screen, I can hear that the carPC is still getting the touch inputs because I set it to make a sound whenever it detects touch inputs.

    I tried connecting two different laptops to the monitor to see if it would display anything, but still nothing. The power light just stays flashing. I've tried pressing the Source button so that it goes to PC mode... but the screen still remains blank.

    Could you please let me know what I can try? I'm hoping not to have to RMA this as I'm in Australia.

    Many thanks

    p.s. This monitor did not fit in my car's standard DIN slot, it was too wide so I had to dremel the dash to fit it. All other standard DIN devices fit fine... I think this monitor is not made to the DIN spec??

  • #2
    Have you checked the ribbon cable? Remove the front cover and wiggle the cable underneath the monitor. If the screen flickers, then you need a new ribbon cable (It's a known issue).

    As for the size, it fit in my car just fine. I know it's longer than the DIN slot, but I don't think it's any larger except the front bezel which is wider... but that doesn't actually go in the slot that sticks out.
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

    Comment


    • #3
      Originally posted by malcom2073 View Post
      Have you checked the ribbon cable? Remove the front cover and wiggle the cable underneath the monitor. If the screen flickers, then you need a new ribbon cable (It's a known issue).

      As for the size, it fit in my car just fine. I know it's longer than the DIN slot, but I don't think it's any larger except the front bezel which is wider... but that doesn't actually go in the slot that sticks out.

      Thanks very much Malcom. I played around with the flimsy cable and found that when I tilted the screen forward, at certain angles, occasionally the screen would appear. I tried pushing the cable in further where it connects to the monitor but that didn't help, it only seemed to make contact when I tilted the screen forward.

      Sounds like I need a new cable, is this covered under warranty or do I have to pay Xenarc? Thanks. (I've already submitted an RMA request.)

      As for fitment, the unit itself excluding the bezel was wider than my dash's DIN opening... I'm not actually sure if it's my dash being narrower than the standard DIN opening, but all other DIN accessories fit in the past. (I have an 05 Subaru WRX.)

      Comment


      • #4
        No reply from Xenarc regarding finding a replacement for the poor quality ribbon cable. Can anyone point me in the right direction please as to an Australian distributor?

        I wonder if the manufacturer bothered to do any wear-and-tear testing... Lucky they're not manufacturing condoms.

        Comment


        • #5
          Hi cheap1, this is covered under warranty if it is still within warranty period. We do perform wear-and-tear testing and this units have received several revisions already and should be pretty robust. There is a great number of these units deployed in Europe for Taxi Cab applications. Anyways, we do have a distributor in Australia. Please e-mail me directly at [email protected] and we will take care of you. And sorry for the late reply, I must have missed your post.

          Comment

          Working...
          X