No announcement yet.

Having very unfavorable experience with MP3Car New Computer

  • Filter
  • Time
  • Show
Clear All
new posts

  • Having very unfavorable experience with MP3Car New Computer

    Hi All,

    I'm a longtime electronic tech, but newbie to carputers.

    Did my research and ordered $599 Beginner! package from Mp3Car. The items arrived at my home in great condition:
    >carputer in VOOM case
    >wireless kbd
    >Lilliput 7" touchscreen (with lotsa nice accessories)
    >Griifin Powermate controller
    >4 USB hub

    I also opted for MP3Car to install Streetdeck and XP..

    On the bench, I powered the unit from 10amp 12 volt supply and it wouldn't do a thing, except make a slight clicking noise every 5 sec. I opened the case and found that the HD power and data cables had not been plugged into the HD; the clicking was CPU fan "bumping" on and off every 5 sec.

    The M2-ATX power supply is not putting out any voltage, so I connected desktop ATX to the motha board; the CPU fan runs, but HD stays silent, monitor stays dark...

    At present, I be pretty unhappy camper. Also, MP3Car didn't provide any restore or boot disks for XP, either. Sucks to be excited about a new endeavor and have it work out like this. I presently have a pretty dim view of MP3Car, mainly due to the MULTIPLE problems / defects.

    Happy CarPC'ing!

  • #2
    have you contacted them or id thid just a general rant?

    I've had nothing but excellent service from the store myself............
    For once you have tasted flight you will walk the earth with your eyes turned skywards, for there you have been and there you will long to return.
    Leonardo Da Vinci


    • #3
      That sucks. They should have tested it before shipping it.


      • #4
        If you ever hear my rant, you'll know that post was just a l-i-t-t-l-e whine...

        I spoke to Adam; he authorized a RMA.

        I certainly don't want to put MP3Car in a general bad light. My phone conversations with them have been extrordinary: friendly, helpful, informative... Ordering the carputer and peripherals went well, too. Everything arrived in great condition, and looks to be quality and worth the price.

        You know, we've all bought a 4-pack of bulbs and found one defective, we've all bought something electronic and had it not work right out of the box...

        But there were just TOO many things wrong electronically, and too many assembly errors / poor component and cabling choices. I have high hopes that MP3Car will do the right thing, and when they do - I'll sing their praises from the housetops. Currently, a $600 outlay for non-op eqpt doesn't feel too nice...

        Happy CarPC'ing!


        • #5
          To be honest, I suspect this problem was something relating to the PSU. Did your board have a P4 connection? Most systems that have a P4 connector will power on but you wont get any output to the screen without the additional P4 connector.

          I hope all goes well for you and please do post a followup to this thread to let everyone know the status. Things happen but what is important is the customer service you receive.