No announcement yet.

2 questions about the Intel D510MO Board...

  • Filter
  • Time
  • Show
Clear All
new posts

  • 2 questions about the Intel D510MO Board...

    Hi peoples.

    Kinda new to this but im trying and learning.

    I have 2 questions about the D510MO board that is part of my recent set up.

    Its powered by a M2-ATX and running windows 7 32bit

    But i have an intel 9465AGN wireless card for it and the comp boots up fine but when i plug the wifi card into the mini pci slot then hit the power button i get nothing, no bios. seemingly nothing. So i unplug it and press the button and it boots up as normal???

    Second question is why wont it let me update the bios? i have an older version and have found the correct newer versions on the intel support page and followed the instructions but everytime i get the message;
    "the program is unable to continue. the bios you are trying to update is invalid for your system"

    Any info thrown this way would be awesome.


  • #2
    About the wifi card - do you mean 4965AGN? Have you tried it in a different computer?

    About the BIOS - how are you trying to update it? Are you using the BIOS recovery option or are you trying to update from within Windows?
    1999 Mercury Grand Marquis GS with: ASRock E350M1 w/4GB RAM, 80GB Intel SSD, Opus DCX3.120, Visteon HD Radio + HDR-USB, PL-18N wifi, OBDLink Scan Tool, BTA6210 BT, BU-353, Win 7 Ultimate, CF 4.0, Alpine MRP-F240 + MRP-T220, RF Punch 1572s, Kicker 8" Comp.


    • #3
      Yeah sorry i mean the 4965AGN. and no i haven't tried it yet in another computer.

      And as for the bios i have tried the express bios update through windows and that failed and i have also tried loading the .bio file onto a usb drive and flashing the bios by going through the F7 menu at the start. also failed.


      • #4
        update* i got the 4965AGN card working. i know i prob went about it the wrong way but hey, it worked.

        cos it was not allowing the pc to power up i left it out and booted it, then plugged it into the PCIe slot while it was running. then restarted the comp and it found it and installed drivers.


        • #5
          if you want update the BIOS of the Intel D510MO, you have to update first to version MO0400P.BIO, then you can update to version 0516

          All version can be downloaded from intel website.

          All procedures are made with F7 key and xpress utility


          • #6
            Sorry for the digging up of my old thread, but I have dusted off the computer and i am trying to have another go at getting it working right.

            I now have the BIOS fully up to date.

            But i am still having an issue with my PCIe WIFI card.

            It is an Intel 4965AGN.

            If i have the card plugged in when i press the power button, it wont even boot to BIOS.
            The fan starts up but the power led does not come on and nothing happens

            The computer boots fine without it installed, so when it has booted up i tried plugging the 4965AGN in, i then go to device manager and disable the other network that shows up, "realtek pcie gbe family controller"
            then scan for hardware changes, it finds the card and installs the latest drivers.

            but most of the time it has a yellow triangle and the message...
            "Code 12: This device cannot find enough free resources that it can use"

            On the otherhand, some times it finds the card and connects to a my network.
            It will continue to work even if i restart the computer, but if i shutdown, then attempt to boot up again, im back to square one????

            I have tried other wifi pcie cards with much the same result.

            Where can i find out what is conflicting with it and disable it?

            Also any other advice would be awesome.
            Im pretty close to giving up and smashing it just for some satisfaction.



            • #7
              Spoke to a few "computer savvy" friends of mine.

              Sounds like possibly that the power supply cant handle everything booting up at once?
              Sounds not right as all the bits were purchased from Mp3car's store and are the the same as the ready built ones.

              Any other ideas