Announcement

Collapse
No announcement yet.

PSU acting weird.. broke?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PSU acting weird.. broke?

    ok, just reinstald my car pc in another car after i crashed my car.
    everything passed the tests in my house, so i connected everything in the car. the pc powered on, but after 10 seconds it shut itself down.
    checkt al my voltages:
    12.5v at my car battery
    12.5v at my wires going in my powersupply (OPUS 150W DC-DC), untill i put them in... then they only give 3v.
    disconnected all the wires going out of the PSU, but still only 3v.
    tried another PSU (some "morex" psu) and this acts the same...
    are both the PSU's broke? or is this normal?
    maybe the fuse inside my OPUS fuse is broke?
    plz help, don't know what to do...

    Greetz

    Dj NRG

  • #2
    If the fuse inside your opus were blown, you wouldn't get it to power up at all.

    No, it's not normal for the lines to read 3v.
    Are you measuring the 12v constant line or the ACC line? Or both?
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

    Comment


    • #3
      Originally posted by DarquePervert View Post
      If the fuse inside your opus were blown, you wouldn't get it to power up at all.

      No, it's not normal for the lines to read 3v.
      Are you measuring the 12v constant line or the ACC line? Or both?
      the constant 12v gives me 3 volt once i put the fuse in (so once power runs towards it)
      haven't checked the acc line, but i think it will give me 12v...
      I'll check it...

      Greetz

      Dj NRG

      Comment


      • #4
        That's very weird, I agree.
        If the fuse is blown, it's pretty easy to tell. There's a strip of metal inside the fuse. If the fuse is blown, there will be a break in that metal. If the fuse is good, that metal will be continuous.

        Here's a couple of photots of a blown fuse side-by-side with a god fuse.

        Blade style:

        Glass style:

        Granted, you may not see the scorch marks on the fuse. Look at the ribbon of metal inside the fuse to see if it's broken or not.
        Have you looked in the FAQ yet?
        How about the Wiki?



        Under normal circumstances, a signature would go here.

        Comment


        • #5
          it gives 12.5v when i don't plug it in to mu PSU. can't measure what it gives when it's plugged it without getting the PSU out of the car (it's installed close to the side of my trunk)

          Greetz

          Dj NRG

          Comment


          • #6
            fuse is ok, just checked that.
            when i plug in the plug from my psu (12v, ground and acc), my acc gives me 4 volts, and my 12v gives me 3v (2.8v)

            strange strange strange...

            Greetz

            Dj NRG

            Comment

            Working...
            X