Announcement

Collapse
No announcement yet.

Reset BIOS, now won't hibernate!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reset BIOS, now won't hibernate!

    Hey.
    I recently had to reset my BIOS blind after I messed up a display setting, I got it all back but now it doesn't seem to hibernate! I haven't changed ANYTHING in windows (xp) and have double checked all the power settings are as they should be but for some reason it isn't hibernating from the carnetix P1290 signal. It does if I manually make it hibernate from windows (and that seems to be taking a long time) but not automatically like it used to.

    The ONLY thing I changed were the BIOS settings (back to failsafe defaults) but have now altered them back to what they were before (I think!)

    What have I missed or is the hibernate taking so long so the p1290 is killing power before it has a chance to complete. I can't tell at the moment as the monitor is an automatic dash one and closes when I kill the ignition.

    It's a VIA M10k mobo by the way
    VIA M10000
    512Mb RAM
    30Gb 2.5" HDD
    Bluetooth, 802.11g, GPS
    Silverstone USB DAC
    Consult (ODB)
    CarTFT K500
    Carnetix P1290
    NLited XP with Road Runner and MapMonkey

  • #2
    The only thing i can think of is to make sure ACPI is enabled...

    Comment


    • #3
      Originally posted by GiODi View Post
      The only thing i can think of is to make sure ACPI is enabled...
      I have this in the power management screen with options for S1, S3 but nothing seems to make any difference
      VIA M10000
      512Mb RAM
      30Gb 2.5" HDD
      Bluetooth, 802.11g, GPS
      Silverstone USB DAC
      Consult (ODB)
      CarTFT K500
      Carnetix P1290
      NLited XP with Road Runner and MapMonkey

      Comment


      • #4
        try loading the optimised or performance settings instead of fail-safe. Fail-safe turns most of the features off.
        Visit my site V8 Scimitar

        SP13000, 300GB SATA HD, 1GB DDR. Opus 150, K301 screen, Cisco WIFI, AQmax GPS, RoadRunner and FreeDrive, Sony MEX-R5 head unit. 4 years installed and it just keeps running!

        Comment


        • #5
          If you're changing those options int he BIOS, Windows likely wont' pick it up.
          It has been my experience that Windows will have to be reloaded to pickup the ACPI mode set int eh BIOS.
          There may be another method, but I'm not aware of it.
          Have you looked in the FAQ yet?
          How about the Wiki?



          Under normal circumstances, a signature would go here.

          Comment


          • #6
            I believe what DarquePervert is saying is correct. I've read on HTPC forums that there are a bunch of registry hacks and such that must be done to enable S3 (standby) after the fact.

            Is there a setting in the BIOS for what to do when you hit the power button? You can try that

            Comment


            • #7
              Bugger, do you happen to know what the reg hacks were (or where I can find out) cos I REALLY don't fancy reinstalling windows
              VIA M10000
              512Mb RAM
              30Gb 2.5" HDD
              Bluetooth, 802.11g, GPS
              Silverstone USB DAC
              Consult (ODB)
              CarTFT K500
              Carnetix P1290
              NLited XP with Road Runner and MapMonkey

              Comment


              • #8
                The reg hacks are for Standby, not Hibernate. The site that I saw them on (HTPCNews.com) is no longer around.

                Were you able to locate anything in the BIOS about the the function of the power button? Did you load the optimized defaults as v8 Scimitar suggested?

                Edit: I believe the reg hack is only to enable your computer to wake up by a USB device:

                # Check your BIOS settings: Make sure your BIOS Power Management settings are set to S3 standby. Unfortunately if it is not set to S3 when windows was installed, Windows will not install the correct settings to allow the computer to sleep in S3 mode. However, just changing the option in the BIOS will override the windows setting on some computers and you may enter the S3 sleep state anyways.
                # Are you using a USB keyboard or mouse? This may be holding you back. For fear of allowing a computer to enter a sleep state that it was incapable of resuming from due to incompatible USB devices, Microsoft decided that if USB input devices were present, it would not allow S3 Standby mode. Fortunately this is easily bypassed through use of a registry entry. Just open regedit and enter the following registry entry as described in this Microsoft Knowledgebase Article:
                HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\usb
                “USBBIOSx”=DWORD:00000000

                Side note: you can use this to allow you touchscreen to wake your computer up, but it doesn't work for me; it just pops right back out of standby.

                Comment


                • #9
                  Man, I was looking at a thread yesterday about this exact problem and there is a program from microsoft (undocumented) that you can open form the command prompt and tell it what ACPI seetings to use if you change the settings in your BIOS, but I CANNOT find the bloody thing anywhere.

                  I'll try to track it down.

                  Got it here
                  I installed my carpc into my pet Kangaroo, mate.

                  Comment


                  • #10
                    Thanks for all these suggestions guys. I will try them out this week and report back.
                    VIA M10000
                    512Mb RAM
                    30Gb 2.5" HDD
                    Bluetooth, 802.11g, GPS
                    Silverstone USB DAC
                    Consult (ODB)
                    CarTFT K500
                    Carnetix P1290
                    NLited XP with Road Runner and MapMonkey

                    Comment


                    • #11
                      Not meaning to threadjack, but I stumbled upon this thread and am wandering if Tim has any updates? In my worklog(Post#21 starting) I had a similar problem with Hibernate after updating my BIOS from the original (A06) to newest (A32).

                      What's the good word Tim? I'm crossing my fingers
                      Current Rig
                      ----------
                      Inspiron 5100 Laptop
                      *2.2 Ghz CPU
                      *368 MB Ram
                      *32meg OnBoard Vid
                      Carnetix 1900 PSU
                      BU-353 GPS Antenna
                      iGuidence Nav Software / Mappoint for POI's
                      Linksys USB WiFi
                      D-Link USB Bluetooth 2.0
                      Xenarc 700IDT
                      Eclipse CD4000 HU

                      Comment


                      • #12
                        Here is the KB article on this issue

                        http://support.microsoft.com/kb/315278
                        --------------------------
                        Software Developed:
                        DS-ATX Controller Interface
                        Laptop Shutdown Controller

                        Considered Projects:
                        TPMS Interface
                        Bluetooth Handsfree Interface (WIDCOMM/BROADCOMM)

                        Comment


                        • #13
                          Also, try looking for a file under the WINDOWS folder called nohiber.txt. It will contain any error messages about why Hiberate will not enable.
                          --------------------------
                          Software Developed:
                          DS-ATX Controller Interface
                          Laptop Shutdown Controller

                          Considered Projects:
                          TPMS Interface
                          Bluetooth Handsfree Interface (WIDCOMM/BROADCOMM)

                          Comment


                          • #14
                            Also, the ACPI registry settings are located at
                            HKLM\System\CurrentControlSet\Services\ACPI and
                            HKLM\System\CurrentControlSet\Services\ACPIEC (Error Control)

                            My system can go into hibernate with these settings

                            HKLM\System\CurrentControlSet\Services\ACPI\Displa yName = Microsoft ACPI Driver
                            HKLM\System\CurrentControlSet\Services\ACPI\ErrorC ontrol = 1
                            HKLM\System\CurrentControlSet\Services\ACPI\Group = Boot Bus Extender
                            HKLM\System\CurrentControlSet\Services\ACPI\ImageP ath = system32\DRIVERS\ACPI.sys
                            HKLM\System\CurrentControlSet\Services\ACPI\Start = 0
                            HKLM\System\CurrentControlSet\Services\ACPI\Tag = 1
                            HKLM\System\CurrentControlSet\Services\ACPI\Type = 1

                            HKLM\System\CurrentControlSet\Services\ACPI\Enum\0 = ACPI_HAL\PNP0C08\0
                            HKLM\System\CurrentControlSet\Services\ACPI\Enum\C ount = 1
                            HKLM\System\CurrentControlSet\Services\ACPI\Enum\N extInstance = 1

                            HKLM\System\CurrentControlSet\Services\ACPIEC\Erro rControl = 1
                            HKLM\System\CurrentControlSet\Services\ACPIEC\Grou p = Boot Bus Extender
                            HKLM\System\CurrentControlSet\Services\ACPIEC\Star t = 4
                            HKLM\System\CurrentControlSet\Services\ACPIEC\Tag = 5
                            HKLM\System\CurrentControlSet\Services\ACPIEC\Type = 1

                            Check for differences, maybe one of these settings will re-enable it. I do know that if you add

                            HKLM\System\CurrentControlSet\Services\ACPI\Parame ters\Attributes = 0x70

                            Then it will be disabled.

                            I'll keep looking for information.
                            --------------------------
                            Software Developed:
                            DS-ATX Controller Interface
                            Laptop Shutdown Controller

                            Considered Projects:
                            TPMS Interface
                            Bluetooth Handsfree Interface (WIDCOMM/BROADCOMM)

                            Comment


                            • #15
                              The application to reset your ACPI settings is here

                              ftp://ftp.microsoft.com/products/Oem...st/Tools/Acpi/

                              It is called DUMPPO.EXE

                              If you had S1 during setup, u can force S3 mode by applying this command lines to the Startup folder:

                              dumppo admin minsleep=s3 oer
                              dumppo ac minsleep=s3 maxsleep=s4
                              --------------------------
                              Software Developed:
                              DS-ATX Controller Interface
                              Laptop Shutdown Controller

                              Considered Projects:
                              TPMS Interface
                              Bluetooth Handsfree Interface (WIDCOMM/BROADCOMM)

                              Comment

                              Working...
                              X