No announcement yet.

Thoughts... Suggestions?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Thoughts... Suggestions?

    I installed my system last November. At the time it included the following components...

    Via EPIA 800-----------------60Watts
    2 x 128MB SDRAM------------2Watts
    1 x 3.5" 20GB HDD------------13Watts
    7" Lilliput 629-----------------12Watts
    4 Port USB Hub---------------12Watts (5Volts * 2.4Amps)
    BU353 USB GPS---------------2.5Watts
    SNHOND03 - Honda stereo adapter -- 0Watts

    I never did any power measurements myself. I just tried to find other people's measurements for the same/similar components. Based on those number I decided to wire both the 7" Lilliput and the 4port usb hub into a spare molex connector I had and plugged that into the m2-atx, so that everything was being powered by the m2.

    Everything worked great for about 6 months, when I upgraded from the snhond03 to a Car2PC adapter. The documentation for that adapter says that it draws all of its power from the car stereo (not USB), so I didn't worry about adding any extra load to the m2. However, things started immediately acting weird. I.e. The system would boot OK, but the touchscreen and Car2PC wouldn't work at all. To fix this I would have to unplug the USB hub power, wait a few seconds and then plug it back in. Then everything would work great. Eventually I upgraded the 20GB HDD to an 80GB 3.5" model. This seemed to reduce how often I needed to unplug/plug in the USB hub. Until last week, when my motherboard died. (Fans spin up, but nothing else happens, no video, no beeps, nothing.) I've tried using a standard ATX PSU in my house and the motherboard does the exact same thing, so I'm pretty sure its not the M2.

    Judging by the symptoms it seems like I'm overloading the M2. But the 5V rail is capable of 8A (12A peak for less than 60sec) and I didn't think I was getting anywhere near that, so I didn't really worry about it too much.

    I've ordered a new D201GLY (intel celeron 1.3Ghz,ddr2 - $52) and some memory to go with it. But I'm trying to decide if I need to re-wire my USB hub to get it off the M2. I did my calculations again (with my new board + ram) and came to a grand total of 149 Watts peak.

    I'm wondering if anyone else has seen the car2pc sucking up more power than its supposed to, or if everyone agrees that this setup should have worked and maybe my 5yr old board just died of old age.

    Thanks in advance
    Is it that it's fun? Or that it lets you forget yourself?

  • #2
    You overloaded the M2.

    Here is what I think happened:

    Pre-Car2PC: All good. No worries. Pushing the very upper limits of the 5v rail.

    Added Car2PC: At and a little bit over the maximum draw on 5v. A laptop HD draws its power from the 5v rail. When a harddrive spins up initially either via booting or coming out of sleep, it draws the most power by spinning full speed. So on boot, with the additional USB draw, there was not enough power for the HD to spin up, so it failed boot check, and the system decided there was no boot sector so didnt boot/resume correctly.

    Switched to 3.5" Drive: Got rid of the overload on the 5v rail, and moved the overload to the 12v rail. While a 2.5" drive takes all its mojo off the 5v, 3.5" drives use the 12v rail to spin the platters (which are bigger and usually much much much much much less efficient) and 5v rail to power its logic (the chips and such). So you dont have anything that would notice (like the usb not working) with an overloaded 12v rail. The CPU will go slower and things will get hotter, but not something noticeable usually unless you are looking for it.

    Now: So after some time of being overloaded, the M2 does it what does best when being overloaded. It fails. Now the M2 failing may just blow itself up, or it may blow its 12v regulator and now you are passing 13.8v to a highly sensitive electronics component. So essentially you bbq'ed your CPU and maybe even your RAM.

    Your M2 is most likely damaged as well. If it is still passing on voltage, then it probably is just that regulator. Check the 12v line as you vary the input voltage to the M2. Dollars to doughnuts it will output what you input with no regulation. (car is 13.8, so hence 13.8 out of the 12).

    Also your mobo/cpu since they are integrated is hosed. I would check your RAM as you may need to buy more. Not just plug it in and see if it works, plug it in and run memtest86. For 512Mb on a M10k it took a little over 8 hours. For 4Gb on a Pentium 4 3.0Ghz it took roughly 5 days to check every sector.

    So now you have learned a valueable lesson. Dont just assume it will work, prove it will work. Or else you will have another expensive lesson.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the Store


    • #3
      I kind of thought that was the case.

      I was originally using a 3.5" HDD though. I've never had a laptop hard drive installed on this system. Also, up until the week the MOBO died, it always booted just fine. That week I got a "No System Disk" error one time before it died. Doesn't really matter I guess, end result is still the same.

      I'm now planning on switching to a laptop disk while i'm in the process of rebuilding.

      I'll have to check my M2. I assume in order to do that I'll have to hook up a power source to both the switched and non-switched lines, then vary the power on the non-switched line and check the outputs. Does that sound right?

      Also, I really don't care about my old mobo/chip/ram. I agree, the mobo/chip are dead, but like i said it was only an epia 800 so not a HUGE loss. I don't have any other computers which can make use of the 128MB chips for that board, so no worries there either.

      Would you suggest then that I find a way to power my USB hub without using the carpc supply? I guess it wouldn't hurt either way eh?

      Thanks for your insight and suggestions.
      Is it that it's fun? Or that it lets you forget yourself?


      • #4
        How can you draw 60w through the USB hub?? Usually USB devices draw no more than 1amp from each port!
        If you only have a 4 port USB hub, the total power there is theoretically 4 amps.

        I think I know why your system was having problem and then got fried. Have a look on the motherboard for capacitors. Capacitors are small cylindrical components, have a search on google for some pics. Are they bulging? Are they leaking? Is there a sort of fuzz at the bottom of the capacitor??


        • #5
          Technically each device can only draw 0.5A (500 mAmps) according to USB specs. There are four ports so 0.5A*4=2.0A. Plus a little bit for the hub's operation (LEDs, its own USB controller, etc). The original AC adapter for the hub output a max of 2.4A @ 5V = 12W.

          So... that 60W is wrong. It should only be 12W. I've updated the math in the first post now. I blame the math mistake on a mistyped equation in excel.

          Which definitely means there shouldn't have been anything being overdrawn on the original system. I was well within the limits of the M2. Even if that cursed Car2PC adapter was pulling power it shouldn't have.

          I have looked at the board quite closely. I was originally looking for any fried chips, but didn't notice anything odd with any of the caps. Supposing that the caps are shot, and I missed it while looking for fried chips. What would cause that, assuming that my power requirement calculations are now correct and within the limits of the M2?

          UPDATE: I got home from work and looked at the capacitors. They are all fine (big green ones and little black ones) all ok.
          Is it that it's fun? Or that it lets you forget yourself?


          • #6
            Ok... last week when everything stopped working I took my mobo inside and hooked it up to a regular desktop atx PSU. Nothing. No beeps, no video. Just fans spinning.

            I disconnected all of the extra hardware... nothing.

            I removed the ram... nothing.

            I followed the instructions, removing the CMOS battery, setting the jumper to reset the BIOS... nothing.

            I tried everything again the next day... still nothing.

            I tried again yesterday... it works. For some stupid reason the motherboard booted up just fine and seemed as if it had no problems at all. I had to set the clock/date/settings in BIOS but other than that everything ran fine.

            Unless anyone has compelling reasons to believe I really do have power issues, I'm going to assume that my motherboard is simply dying. In which case I'll just keep my current configuration and replace the dying board with my new one.

            Even at absolute peak (which should never really happen) I'm not drawing any more than 6A on the 5V line and 7.5A on the 12V line. Since both lines support up to 8A simultaneously I'm thinking I should be ok.
            Is it that it's fun? Or that it lets you forget yourself?