No announcement yet.

Power problems with m2atx.Please help.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Power problems with m2atx.Please help.


    I am currently having problems with my USB hub. In the house it works fine so the problem is not with the hub.

    When i plug devices into the USB hub, the devices struggle to function - ie cd does not read properly, usb stick is very slow, gps stops working after a while and bluetooth is intermittant. However, these devices work fine when plugged directly to the carpc's usb ports!!

    I think that i may exceeded the load of my m2 atx. I have tried the power calulators and it seems ok??

    This is what my m2atx is powering.

    -VIA C7 2Ghz 2.5"
    -Sata HD
    -Lilliput 7" screen (powered from 12v rail)
    -USB Touchscreen
    USB Hub (powered from 5v rail)
    USB Creative Audigy 2 NX (5v rail)
    USB DVDRW Slot (bus powered)
    USB Blutooth Dongle
    USB Wireless keyboard receiver
    USB Stick

    Am i powering too much?

    Also my slot dvd drive works fine in my house pc, but it wont read anything in the car
    (although the lights are on and it attempts to read). The pc is also much more unstable in the car when everything is connected.

    Any ideas?


  • #2
    Looks like you might be overloading the 5v rail.
    You might need to make use of a 5v POL PSU to alleviate that.
    Have you looked in the FAQ yet?
    How about the Wiki?

    Under normal circumstances, a signature would go here.


    • #3
      That makes sense. I have tried without the Audigy sound card and still getting the same probs.