Announcement

Collapse
No announcement yet.

M3-ATX problems.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • M3-ATX problems.

    I have recently purchased the M3-ATX of MP3car.com store.
    I have a problem with this power supply. It is a very intermittent refusal to power-up. Sometimes it would work all day long, switch-off/on as it supposed to do, and today it would just refuse to power-up.
    I have traced all the wiring, even redone in, even done an "interface box": 2 transistor switched relays that control amp and ACC switch (so the PSU is switched via relay separately from other devices on the ACC line). Also amplifier "remote" on is switch with transistor switched relay, as I was thinking that the reason of failure was due to overloading of the Thump feature on PSU (which is not the case).
    The PSU switches on if the jumper set on to Normal PSU mode (no jumper). If the jumper is in any other positions the PSU refuses to turn on. Only thing that happens is that it powers on the Amplifier line for about 5secs and then turns it off (this happens immediately after I turn the ignition key on).
    Right now I have pulled apart my car (to check the wiring and to pull the computer out), and it is 21:30 on local time on Sunday, it means that I have to put it together, because I have to go to work tomorrow.
    I am very frustrated because I wasted whole Sunday on this fruitlessly.
    Other thing is that I am located in New Zealand so shipment of the unit was about 50% of the price, so it is uneconomical to return it....

    At the moment of writing the carpc sits on my desk powered via bench PSU, and still refuses to power up. I would go and just buy new one, that is if it was available for sale in New Zealand.

    PS. I have tried to reset it (as described in instructions) that did not change anything.

    What are my next steps?

    Here is my control box diagram


    Also, I forgot to add that all the voltages check out. (ACC is +12V when the key is on, BATT is 12V constant, the ground is grounded in several places on the chassis). The LED is stupidly blinking on the PSU (not continuously, but pattern is the same every time)....

  • #2
    This is exactly same problem:
    http://www.cartft.com/community/carp...?topic_id=3591

    Comment


    • #3
      Oh and I ain't buying it from these guys:
      http://www.itx.co.nz/product_info.ph...d67a68e5dkohp5
      221.29 New Zealand dollars = 179.178513 U.S. dollars vs ~$120USD with shipment from mp3car store.
      Unfortunately these wankers are the only people in New Zealand that sell these PSU units...

      Comment


      • #4
        I have tried today, and it works now, very strange.
        What can cause this intermittent behaviour? Busted cap? can't see anything else to cause it....

        BTW I have cycled it through power up 10 times, and it powered up every time.

        Is it possible for some sort of spike in the vehicle electrical system to cause this PSU to go into safe mode (that is if it has one)? I will probably get really beefy 18V zener diode and clamp it across battery (something like BZY93C18)....Although I have not picked up any spikes (long ones that is) on MM..

        The car is 1998 Toyota Celica GT4, so I doubt it has dodgy wiring....

        Comment


        • #5
          I know this is a thread mine, but I am having the exact same problem

          The PSU switches on if the jumper set on to Normal PSU mode (no jumper). If the jumper is in any other positions the PSU refuses to turn on

          This thread along with the link in post 2 appears to be the only threads where people are having similar issues.

          The PSU was working fine for 6 months, I decided to disconnect the power to the unit while I went on holiday for 2 weeks. Came back and the PSU does not turn on in any mode other than P0

          If anyone can help, it would be appreciated.

          Cheers.

          Comment


          • #6
            Well, it seems after another reset the PSU appears to be working fine. For now.

            Comment


            • #7
              I had 2 M3's from LinITX - both had the same problem. I got an M2 in the end & thats been working fine.

              Comment


              • #8
                M3-ATX problem

                I also find that sometimes my M3-ATX power supply will not power up. Sometime I just wait a few hours or a few days, then it works.

                It seems like I can speed up the process of returning to life by disconnecting the 12V and Ignition wire and reconnecting.

                Very Frustrating
                1981 DeLorean DMC-12
                VIA SP13000, Xenarc 700TSV, 100GB hdd, 1GB ram, WinXP, BU335 GPS, iNav 3.0, Griffin PowerMate, M2-ATX, HQCT-AM/FM USB Radio (Software by Luc)
                PMD-1208 USB Data Acquisition
                Flux Capacitor

                Kensington USB 2.0 BT Dongle just dangling

                Comment


                • #9
                  hi,The M3-ATX HV is an impressive little power supply. The manufacturer appears to have harnessed the core features of previous smart power supplies into a smaller and more efficient form factor. The only true sacrifice for M3-ATX HV users will be total power output. If you can accept this, you get a high-quality smart power supply which will work for vehicles based on 12v OR 24v systems.

                  Comment


                  • #10
                    I have the same problem,
                    What i found is on/off's switch positive pin is grounded, i do not know why. So each time when PSU trying to power on by ignition signal, is powered off immediately because of grounded pin. Could you please check if it is same in your case?

                    Comment

                    Working...
                    X