Announcement

Collapse
No announcement yet.

m2-atx, not working?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • m2-atx, not working?

    got 12v power, enough amps etc, 12v remote line and a ground

    it worked perfectly, but ive had the pc out-of-action for a while so it hasn't been used. tried it today and it won't work - all the connections are fine and the PSU itself looks A1 condition. the pc just doesn't start up, no noises, no smells, no nothing.

    how can I test the PSU to eliminate this? or is this a common problem?

    i'm confused with what to do as i started building this computer LAST year (almost 2 years ago now) and i'm finally at a stage to put it in

    edit: I cannot bridge the power connection on the pc itself either

  • #2
    the first thing(s) you should do is double-check your power/remote/ground wires and fuses...

    1. fuses: the M2-ATX has an on-board fuse and you should have a fuse at the source of your power and remote wires as well.

    2. power/remote: use a multimeter to verify that there is ~12v on the power and remote PSU terminals.

    3. ground: make sure you have a good, clean ground. factory bolts are often bad ground points due to panel paint and bolt coatings. make sure the ground ring contacts a clean, unpainted, uncoated metal chassis/floor panel.

    good luck
    F150 Truckputer [1.0] (coming soon!)
    Fusion Carputer [2.0]
    Fusion Carputer [1.0]

    Comment


    • #3
      1. fuses - all are okay, i have 2 40amps on the live wire
      2. power/remte - all 12v and making a circuit (I get 12v on the ground to power)
      3. ground is fine (varified)

      Comment


      • #4
        I think I found the problem, underneath there is a copper wire, tiny little thing, less than a mill thick and its deattached from what looks like 3/4" solder spot away.

        Wish me luck, I have no idea how i'm going to repair this

        Comment

        Working...
        X