No announcement yet.

Cant power off pc

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cant power off pc

    Okay so a quick review on my setup...
    I have a dell sx260 powered by a 150 watt inverter. I soldered 2 wires to the momentary power button so I could turn off the computer manually for testing purposes until I can get a power regulator to replace the inverter.

    The problem is I can turn on the computer with the button I added but I cannot turn off the computer with the same button. I can turn it off if I press the original button though. The strange thing is this only happens when I power the computer using the inverter, if I plug it into a 120v outlet my button works just fine!

    I am completely baffled and have no clue what the problem is, does anyone have any suggestions?

    For some reason it worked perfectly for a short time...and then it quit again.

  • #2
    No one has any suggestions?
    Anyways, after playing with it some more if I hit the button repeatedly very quickly and then hold it down it will power down the pc about half the time. Maybe the signal isnt strong enough?


    • #3
      Sounds strange. Dell is known for proprietary things. Maybe they are using some sort of lit button that needs a power signal, not just a ground? If you use the pushbutton to short the contact directly on the original power button it should work.
      Fusion Brain Version 6 Released!
      1.9in x 2.9in -- 47mm x 73mm
      30 Digital Outputs -- Directly drive a relay
      15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
      Buy now in the Store


      • #4
        That is how I wired it. The button is a standard push button similar to these. [media][/media]
        The way the button is lit is it sits next to an LED that has a clear piece of plastic that leads to the external button that pushes the internal button so the actual button I am soldering to does not have a light.

        I am hoping the power regulator I bought will fix the problem since it sends a pulse instead of just closing the circuit.


        • #5
          Ok so I got my DSX12VD and it powers on the computer fine. But once again it will not power off the pc!!! I wired my button back to the computer as well as the DSX12VD and the button works 100% of the time now. It will turn on/off the computer when I press it but for some reason the DSX12VD isnt powering off the pc!
          I have uploaded a diagram showing how I have things wired.

          Is it possible that the wire is too long and is causing the signal not to go through?
          Tested the wire length theory...not the problem!

          I dont know what to do, I have everything correctly wired. I followed the guide here

          I took the wire that came with the regulator and soldered that to the motherboard hoping to fix the problem but it doesnt do anything! I also noticed my button works just fine without even being wired to the seems that the inverter was causing the problems earlier.

          Tomorrow I will get my hands on a multi meter and see if anything is even coming out of the regulator.

          If the regulator is working fine then I dont know wtf to do! This is getting so damn frustrating...


          • #6
            I hate to post 3 times in a row but no one is posting...

            Anyways I took some multi meter readings and these are the results.

            On the computers power switch I get about 3 volts when I push the button, while the button is not pushed I get 0 volts.

            As for my DSX12VD I get nothing from the motherboard switch jumper except when I initially give it power by plugging it into the cars power. When I plug it into the car while running the jumper for the motherboard switch reads 4.7 volts for a couple seconds and it does turn on the computer. However onces I turn off the car the voltage remains at 0, turning the car back on also results in 0 volts.

            Is it possible that I have a bad power supply?


            • #7
              most sdc's work by grounding a pin. So maybe flip the connector? Dells are known for being crazy, so you might need to do some fancy pants things to get it to work. Ill check back later when im not on my phone
              Fusion Brain Version 6 Released!
              1.9in x 2.9in -- 47mm x 73mm
              30 Digital Outputs -- Directly drive a relay
              15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
              Buy now in the Store


              • #8
                I have tried both ways incase I got the polarity wrong.

                One quick observation!
                I am still using my head unit for an am/fm radio and I noticed that when I disconnect this my DSX1VD doesnt turn on at all. The ACC line I have been using is the same one that my stereo uses. What I did was run a wire to the back of the car that is spliced from the wiring harness. Could that be a problem? Is there another ACC line I need to tap? I dont even know if there are multiple ACC lines. Also, my car sends stuff such as warnings that I left my headlight on through the stereo so I have to use one of those T-harness boxes to simulate that. It does seem to be able to tell when the ignition is on though... I have attached another wonderful paint diagram to explain what my setup is.

                By the way, you dont know how happy it is to have someone willing to help or say anything. I dont seem to be getting many posts and no one is answering emails. Does mpegbox have active support? I guess everything is slow because of the holidays.

                So a quick summary... DSX12VD gets power, gets signal to turn on/off, but doesnt tell pc to turn on/off.


                • #9
                  I FIXED IT!!!!!! It seems a knob (P1) was causing the problem. I had already turned it fully counter clockwise but it seems that wiggling it a little made it work... I dont understand why it didnt work but since it works now I dont care and I am finally happy!

                  Oh and I just wanted to make sure to thank jeff at for helping me, if it wasnt for him I probably would of never touched those knobs again!